VST synth not showing


i have installed Ardour on my windows 11.
I am trying to open a VST and play it, but the synth it self is not showing up in it’s own window, so no way to make changes etc…What am i doing wrong?


What VST plugin is it? What steps have you taken so far?

Generally all VST.
For example arturia v collection. There you should se the actual synth in the daw to make tweaks etc etc
… I can play VST with midi keyboard, but i want it to show om screen.

When you double-click on the plugin listed in the mixer strip its GUI doesn’t open?

No, exactly…Very strange

I couldn’t locate a demo version of the entire V Collection, but I installed the demo version of the Modular V3 synth from Arturia’s site. That plugin’s GUI opens as expected when double-clicking on it in the mixer strip running Ardour 7.5 on Windows 11. Someone else will have to jump in to provide instructions on how to debug this further. I was unable to recreate your issue.

1 Like

FYI, I also tried the demo version of Arturia’s CS-80 V4 synth, which is part of the V Collection, and it also opened as expected. Unfortunately, I have no guess what the issue could be on your end.

1 Like

On Windows, we’ve seen this sort of no-GUI behavior caused by out-of-date OpenGL drivers.

Aha. What can i try to fix this?

You could try going to Device Manager and right-clicking on your graphics card under Display Adapters and selecting “Update driver”. This will check if there is a newer driver via Windows Update. If you have a discrete graphics card, I would recommend going directly to AMD or NVIDIA’s site depending on your model and checking for a newer driver there.

Update your computer’s graphics card driver.

Newest driver is installed, so did not work :frowning:

What graphics card do you have? When you click on Properties and select the Driver tab, what version is listed?

Is the plugin 32 or 64 bit? You can’t run a 64 bit plugin in a 32 bit Ardour and I’m not sure if it works the other way around either.

AMD Radeon HD 7700 Version 27.20.20913.2000 (Latest)

This works fine on all other DAW, just not on the Ardour…

Click the little light button in Ardour’s top right, as seen below, after you’ve tried loading the synth.
To see if there’s some error messages


No error messages. Hmm

What Ardour version are you running?
7.5 is the latest, so that’s the one you should be using.

Optionally try the Nightlies, in case there’s a specific bug that has been resolved since 7.5 was released.

Yes latest version. may try the nightlie version and see then.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.