VST support returns to Ardour 2.0

VST support has been re-enabled in Ardour 2.0. To enable it, compile with the “VST=yes” argument to scons. There are some important provisos:

  • you cannot enable VST support and then distribute the resulting binary. Doing so is a violation of several software licenses. If you specify VST=yes, you will be asked to confirm that you are building Ardour for personal use only.
  • you will need to have the VST 2.3 SDK available.
  • the VST GUIs seem more fragile than they used to be (buttons & knobs lock up, mouse motion sensitivity is poor, etc). Investigation and fixes for these issues will be forthcoming.

Watch this space for more details and documentation. We remind you that this is for Ardour on Linux/x86 only. Linux/PPC and OSX do not have VST support yet.

This is the last output, build system is ubuntu dapper:

wineg++ -mwindows -L/usr/X11R6/lib -lasound -lardourgtk -lX11 -lpthread -Wl,–export-dynamic -pthread -pthread -o vst/ardour_vst vst/winmain.o libs/fst/fst.o libs/fst/fstinfofile.o libs/fst/vstwin.o libs/fst/vsti.o -Llibs/pbd3 -Llibs/glibmm2 -Llibs/surfaces/control_protocol -Llibs/libsndfile -Llibs/midi++2 -Llibs/ardour -Llibs/gtkmm2/atk -Llibs/sigc++2 -Lgtk2_ardour -Llibs/gtkmm2/pango -Llibs/gtkmm2/gdk -Llibs/soundtouch -Llibs/gtkmm2ext -Llibs/libgnomecanvasmm -Llibs/gtkmm2/gtk -lardour -lardour_cp -lgtkmm2ext -lmidi++ -lpbd -lgtkmm2 -lglib-2.0 -lgobject-2.0 -lglib-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lgthread-2.0 -lglib-2.0 -lgnomecanvas-2 -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lX11 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lgnomecanvasmm -lasound -lsndfile -lFLAC -llrdf -lglibmm2 -lpangomm -latkmm -lgdkmm2 -lsigc++2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lX11 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lxml2 -lz -lm -lxslt -lxml2 -lz -lm -lsoundtouch -lsamplerate -ljack
/usr/bin/ld: cannot find -lardourgtk
collect2: ld returned 1 exit status
winegcc: g++ failed.

I get the same error with Fedora Core 5.

It seems there are errors in the SContruct, causing scons to try to build the final binary before the lib is ready. Workaround, quite imperfect, but, well, working for me:

  1. build with VST=0

  2. comment out the following lines in the sconscript:
    if env[‘VST’]:
    subdirs = [‘libs/fst’] + subdirs + [‘vst’]

    (the second appearance)

  3. build again with VST=1
    then libardourgtk.so should be there in get2_ardour.

  4. reactivate the above lines

  5. build again.

After install, the binaries will be missing. Copy vst/ardour_vst and vst/ardour_vst.exe.so to the bindir manually.

Ardour sill does not start on my dapper system. I had to add the libdir (which was /usr/local/lib/ardour2) do /etc/ld.so.conf and run ldconfig to get rid of wine’s rather irritating “bad exe format” error.

in step #2, where do you find all that in the sconscript?
2. comment out the following lines in the sconscript:
if env[‘VST’]:
subdirs = [‘libs/fst’] + subdirs + [‘vst’]

I’ve looked at the sconscript and this is what I see:

if env[‘VST’]:
extra_sources += vst_files

I tried different releases of ardour2 and ardour. I really love to get the vst going.

Sorry, it ist the SConstruct that has to be changed.

don’t see that in the latest ardour2 Sconstruct.
this is what I have:

if env[‘VST’]:
libraries[‘fst’].ParseConfig(‘pkg-config --cflags --libs libfst’)

Is there any chance to get this on x86_64 in the near future?


I’m just got lost. I’m not a techie. I would appreciate translation into “human” terms.All I know is that VST support allows us to program sounds from within an application.OK, so for someone who is trying too hard (like myself)… would someone please be kind enough (and patient!!!) to explain all this in English?