VST Support on Mac OS.x Intel

Just in case anyone was wondering, if you want VST’s to work on your Mac you can go ahead and download the Audacity VST Enabler (http://audacityteam.org/vst/). Just place it (and your plugins) into Applications/Ardour/Contents/Plugins and you’re set to go! Took me a while to figure out, so I thought I might as well help out anybody else looking for a solution.

I don’t want to say a wrong thing, but I think to remember that some months ago I managed to run some VST plugins on 64-bit Linux (and 64-bit Ardour of course), too, using that VST enabler.

EDIT: I have reinstalled both DSSI-VST-Server and VST enabler now, and I cannot understand which of the two makes Windows VST work on Ardour. Anyway, Ardour 64-bit with VST works smoothly, and this is the important thing : )

This will work with any other VST->AU bridge too, there are a couple out there. Thanks for the tip though.

Working in latest Ardour?

Anybody still getting this to work in the latest Ardour (3)? I tried downloading the Audacity VST Enabler. I put it in the appropriate place, and then Ardour crashes during startup. It is clearly the presence of the plugin, because when I remove it, everything is once again fine.

Is there an Ardour 3 solution to using VSTs? I’ve got quite a few of them in the appropriate subdirectory (/Library/Audio/Plug-Ins/VST) but they do not show up in Ardour. (My AU plugins do show up.)

Hi guys,
I tried it on the actual version (3.5.308). I put the VST Bridge (from audacity) into Applications/Ardour/Contents/Plugins.
Ardour can open and load my session.
But in the console appear :

[ERROR]: LADSPA: cannot load module "/Applications/Ardour.app/Contents/Plugins/vst-bridge.so" (dlopen(/Applications/Ardour.app/Contents/Plugins/vst-bridge.so, 2): no suitable image found. Did find: /Applications/Ardour.app/Contents/Plugins/vst-bridge.so: no matching architecture in universal wrapper)

And I can’t see any VST in the plug-in list.
Does anyone understand the origin of that problem ?
Thanks in advance

No matching architecture? The vst-bridge from audacity is maybe 32Bit en your osx version is 64bit?

If you got Ardour as a free demo from ardour.org, that is a 64 bit build and will not support 32 bit plugins.

even if its not thought for this use, as Paul said, I could resolve different questions with AULab :
when JackPilot is launched, open AULab to make a first routing using JackPilot , and after that, when Ardour is launched, Ardour " finds " “INs” and “Outs”

but not all are OK

( not tested here)

Yes, this is 64bit version. I understand the problem now. Thank you very much guys.
I know what I have to do : a dual boot on my laptop and use the linux solution : more stable at this time and with the open source philosophy I appreciate so much.


I am attempting to get VST plugins working on my Mac. I’ve downloaded Audacity VST Enabler as suggested, but I can’t follow the next step and place this in the applications folder, as for some reason, Ardour doesn’t have an applications folder on my mac.

Can anyone advise what I should do?

On OS X all applications are represented as a folder located anywhere on the system. You will find Ardour’s wherever you put it. There is no fixed location, although “Applications” is a common one.

You are much better off focusing on using AudioUnit plugins on OS X, and if you insist on using VST plugins, then get a real VST=>AudioUnit bridge rather than the Audacity hack.