vst instruments showing up as effects.

(Musicality Sound) #1

Hi, I’m trying to use fxpansions BFD3 drum plugin in Ardour.

However, Ardour does not list it as an instrument, but as an effect,

I am most concerned about BFD3, but actually, only a few of my VSTi instruments are showing up as instruments, while I have tons that I would like to use…

Any help would be greatly appreciated, I would like top use Ardour as my main DAW.

(Paul Davis) #2

We have a heuristic to decide whether or not something is an instrument or not (since they do not come with their own classifications.

In whatever verson of Ardour you’re using (you don’t say) that heuristic classifies BFD3 as an effect, probably due to its combination of audio & MIDI inputs.

(Musicality Sound) #3

Thanks for the reply.

What is a heuristic, and how can I use it to get Ardour to recognise my instruments?

I am running Ardour 5.12.0, intel 64-bit.

(Musicality Sound) #4

I will elaborate on my problem with BFD3.

BFD3 has 32 audio outs. Now in Reaper, you are given the option to map the 32 outs to different tracks as soon as you add the plugin.

I cannot simply use BFD3 as an effect, because in this mode, I don’t think that Ardour can map those 32 outs to seperate tracks…

Anyway, like I said, practically non of my VST instruments are loading… only a few of them load when I add a midi track. Please help!

(Paul Davis) #5

A heuristic is a semi-flexible rule. In this case, the rule is “1 or more MIDI inputs, 1 or more audio outputs, and no audio inputs”. I would guess that you have a set of “instruments” that all accept audio input as well as MIDI, which Ardour doesn’t identify as an instrument. In the next version of Ardour, this can be overridden by user classification, so you can mark a set of plugins as “instruments” and Ardour will use that rather than just the heuristic based on the I/O configuration of the plugin.

Ardour can certainly map those 32 outputs to separate tracks. There’s no single, simple step to do so, however. This will likely be a feature in the next release.

(Musicality Sound) #6

Thanks for the concise reply, I really appreciate this!

So is there a higher version of Ardour to mine right now, where I can specify which plugins are instruments? If I get that, then can I map those outputs to Ardour, if so how?

(Paul Davis) #7

There is no newer version. I was referring to the next release of Ardour, which will not appear for a long time.

You need to do two things. One is simple: Edit > Preferences > Signal Flow and disable “Use Strict I/O for new tracks or busses”. Strict I/O means that a track created with 2 inputs and 2 outputs (for example) will always have 2 inputs and 2 outputs, no matter what plugins or other processing elements you add to it.

Then just create a track or bus with BFD3 as the instrument. It will have 32 outputs. Add 32 (or 16, depending on stereo-ness of BFD3’s outputs) tracks (or busses, as you see fit) in a single step. Now go to Window > Audio Connections and wire up the outputs from the BFD3 track/bus to the input(s) each of the 32.

You may also find it convenient to set “Connect track inputs” to “manually” in the signal flow preference before adding the extra 32, because otherwise they will be auto-connected to stuff in ways you will need to undo as part of the setup. The automatic setting is generally the right one, but there are circumstances like this where it isn’t.

(Colin M Fletcher) #8

There’s also ‘Fan out to Busses’/‘Fan out to Tracks’, which appear in the right-click menu of the track title in the mixer strip for tracks with instrument plugins that have more than two outputs, which saves having to manually add & connect the tracks or busses.

(Paul Davis) #9

Aha! I had some feeling that might have added that, but I couldn’t remember for sure. OK, so it can easily be done in one step. Excellent, thanks for the reminder!

(Musicality Sound) #10

Hey Paul, thanks again, but I can’t add BDF3 as an instrument! It just doesn’t show up!

(Paul Davis) #11

I didn’t suggest that it would show up. Just don’t add an instrument. Then use the normal way of adding plugins to add BFD3.

Am I right that BFD3 has audio input(s) as well as MIDI inputs?

(Musicality Sound) #12

Hi, I don’t think BFD3 has any audio inputs. It has sounds, but these are triggered by midi only, is that what you mean?

Problems…I can get it to load, but only after I add a plugin before it!

Here’s what I’m doing:

Add a new midi track, with a bass synth (the only vst plugin that shows up as an instrument, out of about 100 plugins)
Adding BFD 3 as a new plugin. BFD3 audio is heard, while the sound of the bass synth is cancelled.

I can get sounds out of it in this way, but I still can’t assign it’s outputs to seperate tracks, I’ve tried Window > Audio Connections, but nothing that suggests 32 tracks from BFD3 shows up!

(Paul Davis) #13

Did you switch away from the Strict I/O setting? Did you try creating a MIDI track with no instrument and then adding it afterwards?

Again, the code we use to decide on whether or not a plugin is an “instrument” does this test:

1) number of MIDI inputs must be 1 or more
2) number of audio outputs must be 1 or more
3) number of audio inputs must be zero

Lots of users have lots of plugins showing up in the instrument list. Maybe give us a sample of some others that you consider to be indisputably an instrument ?

(Fred Rech) #14

Hi Musicality,
maybe BFD will act as you need if un-active the panpot. Could you please confirm?
For showing it, it probably needs to be launched in a VM. Could anyone here confirm that please?
HTH;

(Musicality Sound) #15

Hi guys, I am away for Easter, until Monday, so I’ll get back on this Monday or Tuesday.

Paul, I will go over your suggestions, and Strato, I will try your idea when I get back home.

Thanks to all that are helping me on this issue!

(Musicality Sound) #16

… Strato, what do VM and HTH mean? As I said, I will apply all that you say on Monday or Tuesday.

(Paul Davis) #17

HTH: Hope That Helps
VM: Virtual Machine

(Musicality Sound) #18

Hi guys, my deepest apologies for not replying sooner.

Peeps, some things are working fine. BFD3 is now loading every time, as long as I specify 'flexible-I/O" in the Add Track / Bus window. It registers Midi, when I play it on record, which is fantastic. However, I’m still at my original problem…

Basically, Window > Audio Connections only shows two outputs for BFD3, I can’t see the rest of the 32 outputs.

Strato, I’ve tried disabling the pan pot, it hasn’t worked! How do you invoke the virtual machine?

Paul, here are some examples of virtual instruments that show up as instruments when adding a new midi track;

Bass Station by novation
kontack 5
Piano 1 by sound magic
Sonatina Violin

Many thanks!

(Paul Davis) #19

Actually, I was asking for the opposite: things that are clearly instruments that do NOT show up in the instrument list.

I suggest you ignore the virtual machine remark. I also suggest you get on our IRC channel (link at bottom left of this page) sometime between about 10:00 European Central time and 22:00 US Eastern time, where there’s a good chance that we can solve your issues much more quickly and efficiently than this slow, asynchronous back and forth on a web forum.

(Musicality Sound) #20

Okay, went on the IRC, met up with some really cool people, they did their best to help.

I was directed to the pinout view of the plugin, and to use the ‘channels’ menu in the bottom left hand corner. However, on my plugin, there is no ‘channels’ menu, instead there is a greyed out ‘Automatic’ menu. We couldn’t get past this.

Sample of instruments that won’t show;

4Front Piano module (4front)
Hybrid (Air music technology)
Triple cheese (u-he)

I will try to reply as soon as possible, my PC needs some work.

Any continued help would be fantastic!

Musicaiity