Vital Not Loading on new Ardour

Hi. Today I decided to buy a proper build of Ardour because my own, self compiled version had some very annoying problems. Anyway, I started the new Ardour but it said it could not load Vital.vst3. The problem is that on my version of Ardour it loaded without any issues, but on the new one it throws this error:

VST3 module-path ‘/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/’
[Info]: Scanning: /usr/lib/vst3/Vital.vst3
[ERROR]: Could not load VST3 plugin ‘/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/’: /lib/x86_64-linux-gnu/ undefined symbol: g_task_set_name
Cannot load VST3 module: ‘/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/’
Scan Failed.

So I run sudo apt update and know it throws the same error on both versions of ardour. I have the library installed and updated.

Now I’m stuck with pretty much all of my projects since the lv2 version never worked for me. I have no idea what to do.



Same issue was reported late last year: Not working on Linux: Libraries are not statically linked - #26 by brylie - Bugs - Vital

This specific one is unrelated to Ardour, and distro specific.

Thanks, have a good day.

The 1.5.5 version of Vital is working on Ardour.


Confirmed. Working on Linux and Windows.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.