Visual rendering slow with midi regions

Hello, when I use 6 or more midi tracks Ardour become very slow and lags, the problem is less when zoom in, but if I zoom out when all midi regions are visible it becomes extremely laggy, only happens with Ardour, with Qtractor and reaper I can use a lot of midi regions and work very well, but I need Ardour by it’s routing flexibility. I’m using Ubuntu Studio my processor is AMD A8 with Radeon R5 Video, all drivers working well but with Ardour. How I can fix this problem, I paid for an Ardour 5.12 copy and is useless for me on linux, I tried to use it in many Distros but happend the same.

Have you tried going to preferences – GUI and seeing if disabling/enabling any of the options improves things? Also are you using open- or closed-source graphics drivers? Are you using a regular, low-latency or RT kernel?

This should be a good read: Very slow display in editor window

Thank you for your response, I’m using Ubuntu Studio with Open Source Graphics drivers, the problem is only with midi regions, audio regions perform well, when I zoom out midi regions get worst, and that’s only in ardour, with Qtractor and Reaper I can use many midi regions but qtractor isn’t flexible with routing and reaper doesn’t support lv2 plugins, I need Ardour but I have this situation, I think Ardour coding isn’t so compatible with AMD Radeon graphics because looking for an answer in forums other people have the same problem without solution.
I hope Ardour developers solve this problem or if there’s a solution I would like to find it please.

I’m running a Radeon HD7770 and have zero problems so it might be an issue with a particular subset of mobile graphics cards? I wonder if the official AMD Radeon drivers would make a difference and whether, given you are running a paid binary, you might try tweaking the GPU preferences in order to test disabling acceleration and the one about slow graphical performance as per @x42’s post? If you’ve already tried all these, fair play. Someone else might be able to jump in and suggest a few other things…

Mine is AMD A8 with R5 graphics, I don’t know how to tweak it, it doesn’t have any configuration software, and I don’t know how to do it with terminal.

That’s ok. You would need to install the official Radeon software for Linux from their site assuming that the R5 is included in that driver set (probably). However a terminal would be involved :frowning: and it may well not fix your particular issue so I wouldn’t go down that route if you are at all uneasy with non-GUI stuff. You could, safely, boot up a live ISO of Ubuntu Studio or other distro like MXLinux etc and play around with trying to install graphics and tweak those Ardour settings without fear of messing up your production system. One of the many benefits of running Linux! Another good place to start might be the AVLinux live ISO as it will come with Ardour installed as well as lots of other tools. You could test how your project opens on that live ISO to see if it is an Ubuntu Studio issue.

I downloaded the official driver from AMD and doesn’t install it shows in terminal:
@error: Detected X Server Version ‘XServer 1.20.5_64a’ is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib32:XServer 1.20.5_64a:none:5.3.0-19-lowlatency:)
Installation will not proceed.

My OS is Ubuntu Studio 19.10 64bit

Hmm. The issue is probably that Ubuntu 19.10 is so new that there are no official AMD drivers for download yet. The only ones I see are for 18.04.03. You might have to wait a little while…

In the meantime, do try those GPU tweaks in the Ardour preferences as I’m unclear whether you tried them yet. If those don’t work, try booting something like the live AVLinux distro and see what happens when you open up one of your projects in Ardour. Maybe something under the hood is better configured for your particular system. I personally tried all the ubuntu-based distros but landed on debian-based antiX for my audio stuff as it is so bare-bones and efficient even for older machines. It’s a good time to try that live ISO too as the latest version 19 “Marielle Franco” was released recently and looks great. It’s sister distro (if that’s the correct term) is MXLinux and that’s what I use for day-to-day computer stuff (also brand new version released this week).

EDIT: I should add that with all these distros—music-based or not— it’s a good idea to install a low-latency kernel if not installed by default. To be clear, this is separate from your midi region issues. My choice is Liquorix but depending on the system you might need to go for an older version if, as in my case, it does weird things to your mouse cursor speed etc. I don’t recall if Ubuntu Studio ships with such a kernel out of the box…

Thank you very much for your help, I’ll try with linux mint 17.2 if doesn’t work however I will stay because I have the OS available and I don’t have unlimited data to download all of those images.
Thank you, I appreciate.
I’ll let you know how goes.

@mobi7

To repeat something that @bachstudies mentioned, it is not clear yet if you tried changing the preference setting that was mentioned early on in the thread and see if that made a difference for you. Have you tried this yet? This does not require any new distributions etc. and is a simple thing to test.

    Seablade

@bachstudies was right about the driver and the distro that is too new that AMD original drivers isn’t supported yet, I installed Ubuntu 14.04 lts and found the drivers in AMD support page and Ardour works a lot better, I open the project and it doesn’t freeze like in Ubuntu Studio 19.10, I had a hard time with Kxstudio repos but I could achieve to find many of the lv2 I use. Thank you so much, So now I know what is the cause Ardour freezes with many midi regions, is the open source graphic drivers.

Great news! Glad to be of help…

I’ve been using open source AMD drivers for a few months.

It’s misleading to make out that there is a huge difference between AMD proprietary drivers and AMD open source drivers. They both use the same kernel modules. As far as I know the proprietary part of the AMD drivers only affects openGL, openCL and Vulkan support.

There are two open source kernel modules – radeon (for older cards) and AMDGPU (for newer cards). You’re probably using the radeon module and I don’t think the proprietary part even comes into that. The ‘Radeon Software for Linux’ appears to be the AMDGPU module.

To find out which kernel module is in use you can use :

sudo lspci -v 

Changing the radeon settings involves editing xorg.conf or a file in xorg.conf.d. I use Arch Linux so the exact paths are different on Ubuntu – you can look that up.

I have an R7 260x which is around the same age as an R5. These settings give me good 2D performance :

Section "Device"
    Identifier  "Radeon"
    Driver "radeon"
    Option "TearFree" "on"
    Option "ColorTiling" "on"
    Option "ColorTiling2D" "on"
    Option "DRI" "3"
    Option "AccelMethod" "glamor"
    Option "ShadowPrimary" "on"
EndSection

@merlyn I don’t think that is directed at me but, to be clear, I personally just stated that they might make a difference. I agree that it could be seen as an unscientific conclusion to say that the drivers are alone at fault but the fix of changing ubuntu versions to 14.04 and simultaneously installing proprietary drivers worked for @mobi7 and that’s a good thing!

The true test will be when the latest AMD drivers are released and if they make a difference to his experience on later versions of Ubuntu Studio or whether the distro works perfectly out-of-the-box with the open-source drivers. I assume that there are quite a number of things that could cause this particular issue and along with clicking a few settings in a paid-for-binary Ardour’s preferences panel, trying a new distro or installing proprietary graphics drivers were probably the easiest things to suggest.

One thing that can be said fairly scientifically is that the problem is not with Ardour. :slight_smile:

No, it wasn’t directed at you. I was thinking of future readers of this thread.

There are three driver possibilities for an AMD graphics card :

  • radeon – open source
  • AMDGPU – open source, AMD were involved in writing it
  • AMDGPU PRO – mostly open source :slight_smile: The AMDGPU kernel module with proprietary userland binary.

This way AMD don’t ‘taint’ the kernel and avoid Linus’s ire. (You may be aware of Linus’s Nvidia pronouncement. ) :slight_smile:

I’ve tried radeon and AMDGPU. My card, and probably @mobi7’s card can use either, although AMDGPU’s support of this generation of chips is ‘experimental’ and had to be explicitly enabled. The default is to use the radeon driver, which is why I’m not sure @mobi7 is using AMDGPU PRO.

I found the radeon driver uses less CPU on my sytem which led me to think radeon is the ‘right’ driver for this vintage of graphics hardware.

My HD7770 from early 2012 can use either radeon or amdgpu but, indeed, defaults to radeon. I’ve never needed/desired to change anything based on my usage but then again it is not mobile graphics so perhaps less in need of any tweaking.

Perhaps @mobi7 can report back at some point if and when he tries other newer distros to see if the problem resolves itself without any driver installation necessary. I suspect an Ubuntu Studio 19.10 setting is at fault under the hood somewhere but obviously without access to the system I couldn’t be sure. As I mentioned, based on the conclusions of various other forums dealing with audio on Linux, abandoning ubuntu-based worked for me like magic but obviously everyone’s situation is different.

@merlyn
Section “Device”
Identifier “Radeon”
Driver “radeon”
Option “TearFree” “on”
Option “ColorTiling” “on”
Option “ColorTiling2D” “on”
Option “DRI” “3”
Option “AccelMethod” “glamor”
Option “ShadowPrimary” “on”
EndSection
Experimenting with this, I tried this configuration with Ubuntu Studio 19.10 and when rebooted after login, the screen went white blank with with only mouse pointer visible, at least I backed up the original file I could restore.

Call me paranoid but I saw this coming. Messing with xorg.conf can be problematic especially when the two of you don’t even have the same graphics card. If you are going to experiment, I’d highly recommend using one of the persistent ISOs that allow you to reboot the live distro and keep changes. If everything works, you can then install!

1 Like

Ardour again slow with 6 or more midi tracks, it turns slower and laggy when I zoom out, i think i quit Ardour.

@merlyn I tried it but first was only a white blank screen, when rebooted, rebooted again and now i see everything and ardour works a lot faster, but there’s no brightness control, if i use the keyboard brightness hotkey opens instances of display manage gui with no resolution control, rotation etc, unusable display manager.
The problem is only with Ardour and only in midi regions, I can use Qtractor with many midi regions, Blender and doesn’t freeze, Gimp, Inkscape with no lag.