Video freeze issue with Ardour 4.1 / Xjadeo related

Hello Ardour users and makers,

I just installed the 4.1 release of ARDOUR and I have an issue I never encountered with the Xjadeo player.

The video launches and sync correctly at the first launch and after the first transport operation, it simply freezes on one frame (the audio is fine though).

It also makes a video glitch in the player frame when stuck.

As a test, I tried ARDOUR 3.5.403 from the Ubuntu repository and it works perfectly fine with no further tuning.

I read all the documentation on but there are things I don’t know how to get trough (Like compiling, if it is a solution).

My softwares:
Ubuntu 14.04.2 LTS
Xjadeo 0.7.6-1build1 (From the Software center)
Harvid 0.7.3-2build1 (From the Software center)
JACK jackd 5 (From the Software center)

Any idea what’s going wrong ?

(And thanks for your time)

Ardour 4.1 switched to use mpeg4 as default codec. You need at least xjadeo-0.8 built with ffmpeg (not Ubuntu’s libav). What you describe sounds like the version you have has insufficient support to seek mpeg4 files.

If you got Ardour4.1 from, xjadeo+ffmpeg is included (the Ubuntu version of xjadeo won’t be used). It sounds like that’s the case, because otherwise Ardour would log a message (“Please install xjadeo version 0.8.0 or later” and refuse to launch xjadeo).

Ardour Menu > Window > Video Monitor.

Could you right-click on the xjadeo window and confirm that it is indeed version 0.8.2 (the version is displayed in the popup window)?

If that’s true it’s still a bit of a mystery as to why it fails, but we’ll get there. Please file bug at in that case.

PS. jackd 5 ?? There is no such version of jack. Did you mean jack 2 (version 1.9.10). jackd --version will tell.

In short:
-I bought Ardour 4.1 and downloaded it from, classical install in /opt (ironically the 4.1 demo version I tried before did not hang like that even after a few hours of continuous use).
-The version of Xjadeo is 0.8.2
-Jack version is 1.9.10 (But the Ubuntu Software centre mentioned it as “jackd 5”)

I uninstalled Xjadeo 0.7.6 but the issue stays the same.

Some new things I remarked:
-It freezes only when the first audio source is imported in the project (whatever the audio and the video are), before that the video plays normally.
-If I keep the Xjadeo window on my main screen, the whole system hangs up (I had to ctrl/alt/f1 to reboot from console mode).

More infos:
Video hardware: Geforce GTX770 with 352.21 proprietary drivers.
System has a Intel Core i7-4790K CPU @ 4.00GHz with 32Go of RAM.

Thank you for your help.