very weird behavior producing a loud click out of nothing


I have to describe here a very weird behavior which I have some hard time to debug easily myself :

  • I have a session with 15 tracks and 5 busses. Some of the tracks have a few plugins attached to them :
    CAPS EQ 10 bands
    TAP Stereo Echo
    SC4 comp

So far so good. Now, there’s a spot along the timeline where, when transport is on and rolls on that spot, one can hear a noise (loud click) which, because of some of the plugins, is kinda unpleasant. There are a few things to consider here :

  • each region played at that particular spot does not exhibit any spike (if you monitor them you don’t hear anything strange)
  • and now for the weird thing : if you start the transport at exact multiples of three beats before this spot, the weird noise does not occur.

What I see from the volume meters when the click occurs is a sudden jump on the busses level, not the track level themselves. There is no plugin on the busses. Because a few tracks are plugged to the same bus and that one bus is redirected to another one, the click noise seems to be multiplied in volume. When I mute all tracks, nothing happens. When I solo one track (whatever track), you can hear the click.

I find this behavior extremely weird. Why would it occur if you play from certain starting points and not other locations ? why when transport is activated at 3xn beats before the location where the click is triggered, nothing weird happens ?? why is there a noise at all when all regions are clean ?

I even looked into the denormal handling options (does not sound related to the problem) but it does not inluence anything. Any ideas where to start debugging this ? I of course tried to disable all plugins and so on but I could not find any obvious correlation. The good news is that if I start playing the session from the very beginning, the click does not occur. I tried several versions of ardour but no correlation here either.

you are right when you say there is sth wrong with the plugins in last time. whenever i save a preset and recall it, the name of the preset will be shown only until i close the plugin ui. when i open it next time, the plugin parameters are right, but there is no name of the preset in the top right preset name field.
also i noticed that recalling a preset in tap-reverberator can cause that plugin to produce very, very loud white noise sound, or it might be pink noise, i could not hear so carefully because it is so loud that i am happy my monitors still work…


p.s. a question for paul&co - could this be related to the fact that we all have the plugin versions for longer now - means they are all compiled with an older gcc than the current ardour revision?

i have again and again found this issue, but i am not sure how to reproduce. i have a session here, where i can here a click when the playhead is reaching the ‘punch in’ range i used for the recording.
when i do export a session like that, the strange sound is not appearing in the exported file.


I noticed this issue with punch ranges, which I decided to ban completely from all my ardour sessions until this is fixed. It’s lame because punch ranges are really cool. But this problem makes it close to unusable.

Now, in the problem I described above, there’s NO punching range! which makes it even more weird …

In the past, when I experimented with punch ranges, it was not enough to delete the punch range in order to get rid of the pop issue, I also had to save the session, quit ardour and restart the session. Then the pop was gone. I hope ardour will be rid of this quite annoying issue in future releases.

i am too experiencing both issues, just added the ‘punch’ issue to your report, as this is much easier to describe as the other one.


ah OK! so I am not the only one with the weirder issue … great, at least it is not related to my system. All right, how can we start debugging it in a constructive way ?
I tried all sorts of things but not in a consistent way and I did not spend that much time on it because time is, well, money :wink:
But if someone can come up with a suggestion, I’d be willing to dig it in a more systematic way.

i am agreed with you. the strange noises you are describing are coming totally randomly - at once there is a place in a timeline where they are appearing. no idea what to do!
but you did a good explanation of what is happening.


I am planning to make a full copy of my actual session (which exhibits the problem) and debug this copy if the noise is heard as well. I will start by removing all plugins (ladspa) and add them one by one. I am suspicious when it comes to plugins. Could be another root cause but I never had any click issue when not a single plugin was added to a session. Let’s see …


so I copied the problematic session in order to fiddle around with this issue.
In this debug session, I removed ALL plugings. When you do that, there’s no noise, not a blip and loop ranges, punch ranges, etc are working as one would expect. So far so good. The bad news is that I could not go much further due to what seems like serious ardour bugs :

  • in the non debug sessions, I had previously saved all plugin settings into presets. These presets did not show up in the debug session
  • the 1st plugin I put back was the EQ 10 bands (CAPS plugin IIRC) in the very 1st track. The weird thing is that it was added twice in the track post fader, but also many more instances a bit randomly elsewhere. I removed all those and wanted to call back the plugin preset for that track. Not there … so I closed the debug session and kaboom! segmentation fault. I know the latest 2.x SVN has problems with session closing. No bother, I wanted to reopen the debug session : impossible. No error messages or warning of any kind, except for a message saying that it could not open the session and I should try something else … maybe this message was right, I should get a life :lol:

But back to business : I don’t have time to debug it and I am a bit annoyed that my attempt failed because of other bugs. But at least I know it has something to do with ardour and ladspa plugins. There seems to be something fishy about the way ardour manages these plugins. I don’t recall it was that buggy in the past so I guess a lot of things have happened within a short period of time at that level.


the fucked up noise in my session has disappeared. I don’t know why, this is frustrating not to know but I can tell you a couple of changes I made :

I first fiddled with the fast lookahead limiter plugin (made by Steve Harris) in one track but it just became unusable because of the following : I use the autoplay option almost all the time and each time I clicked on the upper time line to start rolling from the location I wanted, I had that alienish noise. So I removed the plugin, quit ardour and restarted the session. Then I noticed that the noise did not come back systematically as described in my first post. It did come back a couple of times, once when I was boosting levels in jamin and I almost became deaf! :lol:

Later, I added a few more tracks to record drum elements and removed a bus that was no longer needed. Now, the noise is completely gone. I have been working all day yesterday and a bit today, nothing screamed through my speakers …

So I cross fingers that it won’t happen again until this is solved by the devs.

what about just disabling plugins in the original? Maybe you could isolate one plugin and use an alternate

not enough, I’ve tried it as well. You have to completely remove the plugins. But because the preset saving and restoring does not seem to work properly, I did not want to take that risk too far and therefore, I fiddled around with a copy of the whole session. But ardour was to buggy to try to be as systematic as you suggest, it was crashing on me too often due to unresolved bugs.

But again, as I said, the noise is gone for now.