Very low input recording level on Focusrite Scarlett 2i4

In macOS or windows input recording level when I use this card (Scarlett 2i4) is just crazy, it’s really loudly. But when I try to make a record in linux - it’s too quiet (all volumes on my card set to max). In alsamixer I don’t have any options available for this card.
What should I check?

Linux mint, all is up to date.

If you’re using the 3rd generation, then I’m surprised it works at all.
If you’re using first or second generation, the Scarlett series is 100% supported by ALSA if you’re system is “all up to date”. Even if you’re system is 3-4 years up to date :wink:
The few times I need to adjust anything on my Scarlett I use “QasMixer”. I don’t know if its the best GUI for ALSA but it came with UbuntuStudio and it does the job. But I have also run ALSA from the command line and it was showing me all input and output channels, the different mixes, etc. Can you send a screenshot of what ALSA looks like when you try to edit the settings on your Scarlett?

1 Like

@drsaamah In the output of lsusb I see:
Bus 005 Device 005: ID 1235:800a Focusrite-Novation Scarlett 2i4

It looks like I have the 2nd gen. I’m absolutely sure it’s not 3rd gen. I think it’s 2nd gen.
And that’s my screenshot of alsamixer:

Does the 2i4 have a software controlled hardware mixer? The 2i2 doesn’t (only physical knobs).

Likely MacOS increases the gain in software. Coreaudio allows that and I think it also has “auto gain” enabled for microphone inputs, perhaps that auto-gain setting was also enabled for the external soundcard?

A quick web search found

This is no-go when recording music… now search the web for “how to disable mic auto-gain on MacOS” :slight_smile:

@x42
Robin, macOS 10.14 doesn’t allow to control my card via software options. I can control the volume and others only with pysical “buttons” on the card but not with button on my keyboard. Using macOS I can control recording volume only using the recording volume slider on the audio track in LogicPro :slight_smile: but it records really loudly.

So that’s gain added in software, no different than moving up the fader or trim-gain in Ardour.

Except Ardour always records the input as-is, without prior gain.
How low is the signal level when recording? Digital peak-meters around -20…-15 dBFS is good target.

Sorry but I don’t know how to measure dBFS in Ardour :slight_smile:
Looks like I need to gain my sound manually after recording it? But how to do it properly? :slight_smile:

In the mixer window, look at the peak meter, here max was -16 (numeric display) and current is at about -25:

image

You may also find the following post (and linked video) helpful: Clipping on master without any track clipping

Ok, it goes between -13 … -20. Looks not bad? But how to make more gain as for the volume of playing audio track? :slight_smile:

And my hardware recording volume of mic is about 95% (it’s a physical knob on my card).

That’s good, most analog/digital converts work best in this range.

Turn up the trim control, the small dial at the top of each mixer-strip:
image

see also https://manual.ardour.org/ardours-interface/audio-midi-mixer-strips/

However if you record many tracks and sum them… a level of -15dBFS on each individual track sounds about right.

What instrument are you recording?

Thanks for the advices!

Just my voice. It a microphone.

Hi…

I have the same 2i4, but I get very high input volumes and it is never an issue for me, except… do you by any chance have a graphics card with a HDMI output? Reason I ask, is I had problems with my system (and any version of Linux I use) trying to use my graphics card as the primary soundcard.
Took a little time to get it sorted but I now have a clear method which works every time.
Click on the speaker icon on your taskbar and take a look at the output devices, make sure the 2i4 is the only one…

What microphone? That (95%) is a lot of gain to be adding in hardware unless you are using a particularly insensitive microphone (Shure SM7 for instance without a cloudlifter or similar) or a very quiet voice. I have the larger brother to that and with an NT1, NT2, or SM7 with cloudlifter, I don’t have to add that much gain IIRC for a typical not-loud voice. Going oof memory about 2/3-3/4 on the knob was about right IIRC.

  Seablade

Just to be clear, while your basic premise of checking the input device used to make sure it is the correct device is good, Ardour in Linux should not be affected by this setting. Generally on most desktop distros this is controlling PulseAudio which Ardour should not really be using for many reasons (It may work fine for some people, it just isn’t recommended).

       Seablade

Yes, I use GTX 980 with HDMI outputs but my linux doesn’t recognize it as a sound card :slight_smile: In the settings I’ve choosen only 2i4 as my primary sound card for both input and output devices.

RODE NT1-A.
I’ve activated +48v on my card.

So this is slightly seperate from your issue you posted about (Which is still a thing)…

That seems like a lot of gain on the preamp for that microphone. Are you sure you aren’t clipping the microphone? Going off memory there should be an LED ring around the gain control on the Focusrite that would light green, yellow, red depending on signal strength, you should be in the green for the most part with occasional bumps into yellow being fine, but shouldn’t be hitting red.

And of course I have to ask the obvious question, you have it facing the correct way (With the gold dot facing you)?

     Seablade