“” is not being created ??!!??

Attempted to compile from source a “checked” out Ardour2 (648-build) and get two notable errors, having to do with (guessing) internationalization? output:

Generating in gtk_ardour/po
Updating pot file:
intltool-update -p -g=gtk_ardour
/usr/bin/xgettext: error while opening “…/” for reading: No such file or directory
ERROR: xgettext failed to generate PO template file. Please consult
error message above if there is any.
scons: done reading SConscript files.
scons: Building targets …
Substituting vars from into ardour.rc
g++ -O3 -fomit-frame-pointer -ffast-math -fstrength-

% xgettext (GNU gettext-tools) 0.14.5
Copyright © 1995-1998, 2000-2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
Written by Ulrich Drepper.

What is it that is responsible for creating “…/” (from the “{ardour2}/gtk2_ardour/po” directory, aka the gtk2_ardour folder). And what might cause this file to be missing or not created during some step?

Later on in the compile processes:
g++ -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -DARCH_X86 -mmmx -m3dnow -march=i686 -msse -mfpmath=sse -DBUILD_SSE_OPTIMIZATIONS -Wall -DHAVE_LIBLO -DENABLE_NLS -DHAVE_GETMNTENT -Woverloaded-virtual -DPACKAGE=“libpbd” -D_REENTRANT -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DLIBSIGC_DISABLE_DEPRECATED -DHAVE_EXECINFO -fPIC -I/usr/include/glib-2.0 -Ilibs/sigc++2 -Ilibs/glibmm2 -I/usr/lib/glib-2.0/include -Ilibs/pbd3 -I/usr/include/libxml2 -c -o libs/pbd3/pool.os libs/pbd3/
In file included from libs/pbd3/pbd/pool.h:29,
from libs/pbd3/
libs/pbd3/pbd/ringbuffer.h: In member function void RingBuffer<T>::reset()': libs/pbd3/pbd/ringbuffer.h:51: error: there are no arguments tog_atomic_int_set’ that depend on a template parameter, so a declaration of g_atomic_int_set' must be available libs/pbd3/pbd/ringbuffer.h:51: error: (if you use-fpermissive’, G++ will accept your code, but allowing the use of an undeclared name is deprecated)
libs/pbd3/pbd/ringbuffer.h:52: error: there are no arguments to g_atomic_int_set' that depend on a template parameter, so a declaration ofg_atomic_int_set’ must be available

Any ideas?

The only thing that stands out is a “gtk2_ardour” exist, but see references to “gtk_ardour” ; made a symlink from gtk2_ardour -> gtk_ardour … it didn’t seem to help.


look at the source… trying to figure out where g_atomic_int_set is declared/created

Suspect that some systemwide include is missing – although glib.h should be it (which IS in the source) – according to

even changed the include to
#include <glib-2.0/glib.h>

(didn’t help)… I think I might need to upgrade to newer glib2 libraries… cannot find g_atomic_int_set anywhere, via various grep “g_atomic_int_set” * / […]"

UPDATED -> found the latest glib here:

(could only find glib-2.8.x at the gtk website)

I hope this does it!

UPDATE#2 -> still compiling but got much further… I suspect that was it. Perhaps updating the links for the glib-2.10 to point to the URL I have above – it currently points to which doesn’t have the latest glib src!!! A stumbling block for me and I’m fairly src-savvy (I did figure it out w/o external help tho smile)



Wow… big different with the interface… FUN FUN!

Have Ardour2 running… now testing/learning!

The colors need tweeking, dark font on dark background. etc…


I have a nice color theme working nearly 100% now. I’m at work,but I’ll post it tonight.

Basicaly it takes all the colors of your window manager theme, and just adds the specific colors to make the rec button blink, the solo button green, etc.

There are stil a few ardour specific colors missing, but the interface is usable, and looks like all other apps on your box.

Marc-Olivier Barre,
Kinoko en Orbite

That would be helpful… My eyes… I was sort of blinded.

I poked around with that color changing dialog thing and never did get anything that worked.

I also tried to figure out where the color settings are saved… looked in ~/.ardour2/* and //(share|lib)/ardour2/ , etc…

Is Marc for short good or Atreju better? I am guessing you use gnome for the window manager?

I am guessing it borrows the colors from the gnome window manager settings… (as you seem to be confirming)

##UPDATE## Loaded a gnome theme inside the gnome manager and loaded ardour2… colors better. Switch to another window manager (KDE) … colors back to white on white, or black on black (or whatever) odd-ball hard to use (see) combinations. changed colors in KDE, still no-go! This could be an issue with other window managers (trimmed down ones, like twm or whatever).

##UPDATE#2## It appears that KDE offers GTK compatible color “theme” support and somewhere there is a setting (or settings) in KDE that needs tweeking … see:

The solution, uncheck (disable) “Use KDE color settings for non-KDE apps” down where select different color themes.



So, Paul, the first error about “” appears to be not important ?? aka it will be fixed later on!?


I am guessing you use gnome for the window manager?
Gnome is my desktop, so I’m not too sure how my tweak would react with kde. You could give it a try though. Grab the file from here :

it is still incomplete, but at least for those who use gnome, it should make your ardour look like any other gnome app. For KDE users I tend to think that It will make ardour look like the other gtk2 running on you kde desktop, exept for ardour “special” colors like the flashing record button, or the green solo button, etc.

Is Marc for short good or Atreju better?
Marco, Marc, Atreju, whichever you like most :wink:

Marc-Olivier Barre,
Kinoko en Orbite