Varispeed: "LV2 Convolution" plugins no output

When I turn varispeed on (e.g. 1 semitone slower) all tracks with the LV2 Convolution plugin stop outputting. If I bypass the plugins then they play.

Are they not compatible with varispeed? I can’t find anything hinting at what the cause might be.

Yes, and for that reason the plugin was deprecated before Ardour 6.0 was released, and superseded with x42 Zero Config|Latency Convolver (“x42-IR Convolver Mono/Stereo”).

You may already have that plugin installed, various GNU/Linux distros package it since 2019.


Tech details:

Since 6.0 Ardour does vari-speed playback by resampling in/out port data.
So to play 1 semitone lower, the session processes 94.3% of the samples for each process-cycle, and the result is up-sampled for playback.

This can lead to non-power of two cycles. e.g. at block-size 1024, the session, and all plugins, process 996 or 997 samples each cycle.

In Ardour 5 and earlier versions the same could happen when looping, that also result in partial process cycles.

FFT, by nature of the process, requires power-of-two data blocks, and the original convo.lv2 plugin only worked with blocks that are 2^N.

The new zconvo.lv2 addresses this and allows for arbitrary process block sizes.

1 Like

Awesome.

No, I didn’t have it installed. I’m still using the previous version of AVLinux (2020).

Downloaded, installed and problem solved. Thanks Robin.