Vanilla Ardour Plugins in Mixbus

Ok, if you miss in Mixbus the plugins that came with the Mac OS X Ardour package, I have found a simple solution, assuming that you have both packages loaded.

Make sure that neither application is running. Also note that while this worked fine for me, your mileage may vary, and, if you break it, you keep it, and it’s not my fault… :slight_smile: Here’s how I did it.

In my case, Ardour and Mixbus are in the regular Applications folder, so I opened the Applications folder in Finder, single-clicked then right clicked on Ardour, then selected “Show Package Contents.” This brought up a Finder with a single folder, “Contents”. I double clicked “Contents.”

I then did the same sequence as above with Mixbus.

So I then had two Finders open. In the one for Ardour, I right clicked the Plugins folder, and selected Copy “Plugins”. I pulled up the Finder for Mixbus, made sure I was in the Content folder, right clicked in the blank area, and then selected Paste Item. A dialog asked if I wanted to replace the existing Plugins. Once I was sure, I clicked Replace.

The next time I started Mixbus, the CAP, TAP, CMT, and other plugins I use very often were in their places and worked just fine.

I maybe mistaken, but I think the plugins are already there, it’s just that they show up under the name of the author.
on my computer they do.


Or you know… you could just install the plugins via the packages on this site and have them in both without having to do this everytime you download a new Mixbus package;)

dhjoe the above is likely why they show up for you by the way.

By the way, ‘Vanilla Ardour Plug-Ins’ isn’t really a good descriptor. They are LADSPA plugins, nothing to do with Ardour at all besides that Ardour loads the LADSPA plugin format, much like it can load AUs on OS X.


The system search path is in /Library/Audio/Plug-Ins/LADSPA

There are a few installable packages I can probably get you the links to, it seems the page that did have them no longer exists. Gimme a bit(And remind me:)

The system search path is in /Library/Audio/Plug-Ins/LADSPA

Cool. Much simpler, and, well, seeing what I’ve seen thus far in OS X, pretty logical. If only the macports uninstall was as simple… but it’s done. I guess I can’t do both my GNU Radio building and Ardour building on this OS X box (GNU Radio requires macports to run, not just build). OT: Using GNU Radio in OS X so that our pulsar researcher here can use his Macbook with a USRP and the swinburne TEMPO suite to do pulsar timing research with our 26 meter radiotelescopes… see

There are a few installable packages I can probably get you the links to, it seems the page that did have them no longer exists. Gimme a bit(And remind me:)

I speculate that it might have gotten clobbered by the donationware/download enhancement [EDIT: No, it didn’t… it appears to have been removed concurrently with the deprecation of the X11 OS X port, since the Native OS X port has LADSPA plugins bundled.]. I found the swh package (through googling for ‘LADSPA OS X’), and tried to back up to the directory to see if there were any others, but got the donation download page instead… Suggestion [EDIT: to Paul, not Seablade]: consider putting the links on the page. [EDIT: Not really necessary except for those who want them in Mixbus. With Paul’s permission I can post them in this topic, or I can host them here, for that matter. As a note, the Audacity download page either does or did link to the SWH set hosted on for Audacity for OS X.]

And if anyone has built a bundle of JAMin… although in my broadcast, which I produced on Mixbus for the first time yesterday, I found that the Mixbus channel dynamics processors and the master bus limiter/dynamics processor/tape sat combination, with just a little EQ, sounds just as good on-air (on-air is after an Orban Optimod 9200) as JAMin ever did. But I wasn’t hitting the multiband comp hard, primarily using the Boost, EQ, and Limiter in JAMin. Mixbus does all those without plugins; the EQ might not be 30 band, but it is sufficient for my purposes. And the tape sat in Mixbus sounds substantially smoother than JAMin’s Boost. Mixbus for me was worth the effort and the cost.

Perhaps that last paragraph belongs in a topic thread under How To…

@dhjoe: The dmg that I downloaded when I purchased Mixbus a while back had a completely empty Plugins folder. Which is part of the reason I donated for the full Mac OS X version [EDIT: of Ardour, not Mixbus…drat H1N1!], which has plugins already.

@seablade: By “Vanilla Ardour Plugins” I’m referring to the set of LADSPA plugins that comes bundled with the Mac OSX Ardour as currently available. Sorry for my wording, it has been a long week with me, two of my five kids, and my wife dealing with the novel H1N1 aka ‘swine’ flu. So perhaps a poor choice of words; I know re-reading some of my other posts in the last couple of days I’m somewhat confused at my own wording…

In any case, though, are the non-swh plugins that come packaged in the Mac OS X Ardour package available for separate download? I couldn’t find them anywhere else, and I use the CAPS set more than the others. Some of the CAPS and TAP plugins (among others) are bundled in in addition to the swh set (which I found here); I’ll admit that I didn’t fire up Mixbus (while it still had an empty Plugins folder inside the after dragging the into applications but before copying the Plugins from the to the; I assumed that wouldn’t look inside for more Plugins. So I’ll reserve the right to be wrong on that. And I’ll need to dig into the code a little to see what path the search for plugins is system-wide, because having a single Plugins install is more efficient than more than one…

Seablade is right, I did install the plugins way back when I first installed Ardour, that’s why they showed up in Mixbus
once I installed that, so I was mistaken…

@seablade: I found the four that used to be on the osx_system_requirements page. It makes sense, now, as the native OS X includes 117 LADSPA plugins; the four links I found were more for use with the now unsupported X11 build. Since you clued me in that there used to be a page with those links, I used the WayBack Machine to find them.

Which of course means my speculation was completely incorrect; the plugin download links went away because the X11 OS X Ardour went away, and the Native OS X Ardour doesn’t need them.

Mixbus, on the other hand, might be able to use them (and I haven’t tested that, nor will I likely test that, since I copied the 117 LADSPA plugins from my Native OS X to the…)…

Yes a bundle exists of Jamin as I am the one that did it;) Sadly it is not great yet, primarily GUI responsiveness is horrible at this point any time it is processing audio. Do a search here and you will find the link.

primarily GUI responsiveness is horrible at this point any time it is processing audio.

Sounds not too different from Linux…at least with a lower-end machine, GUI responsiveness noticeably lags with JAMin. Will search, though, and maybe can help figure it out. [EDIT: found it and downloaded it]

Heh I have a patch of the work I did to get it to that point around here somewhere. I suspect my problem might be either in optimization of libfftw, or a threading issue, but I am not certain which if either. I have a list of things to fix on it in my email box, but other htings have to come first.