Using two different soundcards with ardour

Hi all.

I wonder if there are any news according the usage of two differnet soudcards. I have an old Terratec EWS88MT and a Behringer XR18 , both get recognized by jack, both standalone run without any troubles in ubuntu-studio 20.04 with jack2.
Can I use them together? That would be great.

Do I have to create a “virtual” Soundcard" in .asoundrc or does jack2 manage to set the clock for both?

I did not find any recent information on that.

Regards,
Sven

Most of what I could type is already done here:

https://jackaudio.org/faq/multiple_devices.html

Seablade

Hi seablade,

I already read this, but stumbled over:

  1. Use the JACK2 audio adapter(s) (Jack2 only)

More information is needed on this option

I hoped someone could give this more of infornation. Does it work with jack2?

You’re usually much better off using alsa_in/out (or better yet zita-ajbridge) tools.

Unless if you want to use one device for input, and the other soundcard for output (not combine both In + Out of both). In that case Ardour/ALSA (no jack) makes this trivial.

Hi Robin,

actually I want to use 8 Ins from the Terratec and all 18 Ins from the Behringer.
Output through the Behringer.
I don’t understand why to put alsa_in or zita-a2j inbetween when jack already offers all Ins and Outs?
Can’t jackd sync the two cards by default?

No it cannot.

To use multiple audio-interface their sample-clocks have to be synchronized. One interface is the master, and data from others has to be resampled to match the clock of the main device.

In your case: start jackd using the Behringer (for both in and out), then run alsa_in -d hw:XXX (replace XXX with the ID of the Terratec) to make those inputs available in addition to the behringer ones.

Alternatively you can use zita-a2j -d hw:XXX – zita-ajbridge is a drop-in replacement for the alsa_in/out tools which come with jack. zita-aj2/j2a offers better quality at lower CPU usage.

Okay, I understand.
On ubuntu-studio jackd starts on system start.
Can I automatically start zita-a2j somehow?

I don’t know (I don’t use JACK, nor ubuntu), so someone else may chime in.

I do however recall that qjackctl has an option for “after start-up” script in the Setup > Options. you could add zita-a2j -d hw:2 & there.

Thank you so far.
When I was checking a few things right now I realized that zita-ajbridge seems automatically be startet by ubuntu-studio-control.

ps ax gives

2976 ? SLl 0:06 /usr/bin/zita-j2a -j EWS88MT,0,0-out -d hw:EWS88MT,0,0 -r 48000 -p 64 -n 3 -c 100
2977 ? SLl 0:03 /usr/bin/zita-a2j -j EWS88MT,0,0-in -d hw:EWS88MT,0,0 -r 48000 -p 64 -n 3 -c 100

So, am I right, that this is, what I was looking for?

Just wondering why there are zita-a2j and zita-j2a zombies after stopping ubuntu-studio-controls - but not too much… :smiley:

Sounds like an older version of studio-controls. The newer version is available from the backports PPA

Hi.

I upgraded to the ppa. Sadly it shot everything working before into pieces. Very unsatisfying.

I rolled that back. Everything fine now, except the zombies.

You need to stop those clients before stopping jackd. If you start them from a terminal just use ctrl-c in the terminal, otherwise you need to send a signal to the processes to stop. I’m not familiar with ubuntu-studio-controls, but with the typical qjackctl GUI software for configuring jackd there is a section to configure starting and stopping other applications when you start and stop jackd, perhaps ubuntu-studio-controls has something similar.

Otherwise you can just use “killall zita-a2j” and “killall zita-j2a” after you stop studio controls to kill those processes.

Hello and thanks for all the ideas.

Finally after 2 days of hard work I managed to get things to work as wanted.
I still don’t know where to configure the zita-ajbridge in latest studio controls, but with a mix with qjackctl it works.

Uncreative time, though. I prefer to work on music rather than messing around with technical issues :slight_smile:

Thanks for the help again.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.