Using my USB interface

Please help! I have recently installed Ardour 4 onto my Mac. I have been using it to mix some tracks I recorded previously, and had no issues with this. Recently I got a USB Interface (Behringer UMC22) When I start up Ardour, it seems to recognize that the interface is there, yet I have no idea as to how I can actually record through it. I have not installed JACK yet, but when I went to their website, it wasn’t very clear as to how and where it should be installed. Honestly I’m not a very computer savy person, I just really like Ardour and what it has to offer. Any help with this would be much appreciated!

have you ckecked the FLOSS manual

You do NOT need JACK to use Ardour on any platform.

It is optional and needed only if you want to wire Ardour into other applications. Don’t make you r life more complicated that it needs to be.

That’s good to hear! In that case, what am I doing wrong when it comes to recording? I’ve got the interface hooked up to my mac. The settings in my mac are set to use the interface as the audio input. When I open Ardour, I select the interface as my input. What I don’t understand is how I can actually use the interface to record in Ardour. I checked the manuals, yet I feel like I’m missing something very obvious. Thank you all for your time and patience!

Have you ever recorded anything in Ardour before?
There are several ways to start recording, but I usually record-enable the tracks I want to record (the circular red button on the mixer strip, which lights up when enabled) put the playhead in the right place and then key shift+spacebar to start recording.
You can also click on the big red master record button and then the play button to start.
If you are doing all that and nothing is recorded, what do you see instead?

I tried all of that. Ardour acts as if it is recording something, yet when I play into my interface, Ardour shows no input levels and records only a completely blank track. I know it’s not my interface, as I tested it on Garage Band and it worked fine there.

Have you connected the input from your interface to the track? At the top of the track’s mixer strip under the tracks name there’s a button to connect/disconnect inputs to the track. Try that.

Just tried it. I see options for “add audio port” and “add midi port”. Neither of these seem to solve my problem. I must be missing something…?

@adamham: i suggest you get on IRC and get this issue solved in real time rather than schlepping around with web forums. See “Support” above right for details.

Will do! Thanks for all the help!

@adamham: (1) on IRC you need to stick around (2) US Eastern time (UTC-5) plus or minus 3 hours daytime is the best time in general to reach people who can help.

Sorry about that! I’m a bit of a digital clutz when it come to these things! Thanks for the tip!