Using MIDI in Ardour via ALSA devices

How much functionality has been given to MIDI in Ardour 3 thus far? I can see Ardour in the MIDI panel of qjackctl, but I have an Emagic AMT8, which uses the snd-usb-audio ALSA driver and therefore shows up in the ALSA tab.

Any way the twain can meet?

Ardour3 utilizes Jack-MIDI. You need a version of Jack compiled with MIDI support.


I’m assuming since Ardour shows up under qjackctl at all that I’ve got it.

But my question is this: can something that shows up in the MIDI tab somehow be connected to a MIDI device that shows up in the ALSA tab?

There are multiple ways to accomplish this. Either a2jmidi which will present alsa devices as Jack MIDI ports, or you need to tell Jack to actually use MIDI via the -Xseq or -Xraw switch. I believe there are ways to do this in QJackCTL’s settings page(Check for MIDI driver) as well.


I’ll check those out. Thanks for the tip - I really appreciate it!

I’m looking into this again. I have not been able to see how to connect Ardour to my AMT8 via a2jmidi using a2jmidid and/or a2jmidi_bridge. I see no -Xseq or -Xraw option in Qjackctl and JACK crashes if I try to use those switches manually. What should I try next?

hey audiodef… I have an AMT8 and a UNitor mk 2 both work fine with a2jmidid … you need to use a2jmidid -e … you can setup qjackctl to run this after launching jack…

I actually use ladish instead of qjackctl these dats (jackdbus) and have an application configured at level 1 for a2jmidid -e … it calls it a bit weird as it labels it as failed… (I’m still working out how to submit a bug to those guys)… but it actually works … it means you can create a “studio” with all your default MIDI connections so yo u don’t have to manually connect everything up each time … I used to do this with a bash script … but changing defaults e.t.c. became a pain…

Thanks, allank! a2jmidid -e works if I run it manually after starting JACK via Qjackctl. How do you get Qjackctl to start it? I looked at Setup -> Options and tried using “start script after JACK starts”, but whether I just put a2jmidid -e in there or put that into a bash script to be called, Qjackctl just freezes on me.

You can put “a2j_control ehw start” in QJackctl’s “start script after JACK starts”.

HI audiodef…

I think I put it in as “a2jmidid -e &” in the same spot, this effectively forks a2jmidid to run in the background.