Using Mbox 2 with Linux and Ardour

(zenseidk) #1

Hello,

I’ve done a bit of work on trying to get Mbox 2 working. My card didn’t “just work” so I had to do a lot of searching and I didn’t find the exact recipe anywhere, so to help the next guy, here’s my rundown on how to get it working.

System:
Ubuntu 18.04 and Debian

Symptom:
Mbox 2 registered correctly, but when I checked with dmesg in the terminal, I would get a timeout error message and the device would get ignored.
There was no light in the card and nothing worked.

Solution:
My firmware was version 1.24 and that was apparently too old, I had to upgrade it.

The version that I upgraded to was version 1.43 from http://secure.digidesign.com/services/avid/kb/downloads.cfm?digiArticleId=24364
I first installed the latest driver (XP in VM) and then I used a firmware flash tool on windows XP SP3 in a virtual machine to flash the firmware.
downloaded from here: http://secure.digidesign.com/services/avid/kb/downloads.cfm?digiArticleId=24364
It took several tries and reboots before it finally flashed correctly, but it worked in the end.

Getting a working XP system was the hardest part of the process.

At one point, I got a missing MCF71.dll error and I had to use a different XP VM image. DOn’t know if it’s related.

I tried to use the Mac_INTEL version on a 2011 macbook air, but it didn’t work since the program was apparently for power PC architecture, even though it should be for Intel platform.

(Viktorsmari) #2

I use Ubuntu Studio 18.10 on my Lenovo 2012 laptop (I also used Ubuntu Studio 16.04) and Mbox 2 works very well with both of them ‘out of the box’. Here is my dmesg log:

[196181.702624] usb 3-4: new full-speed USB device number 15 using xhci_hcd
[196181.862774] usb 3-4: config 1 interface 2 has no altsetting 1
[196181.862776] usb 3-4: config 1 interface 3 has no altsetting 1
[196181.862779] usb 3-4: config 1 interface 4 has no altsetting 1
[196181.862780] usb 3-4: config 1 interface 5 has no altsetting 1
[196181.866091] usb 3-4: New USB device found, idVendor=0dba, idProduct=3000, bcdDevice= 1.43
[196181.866094] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[196181.866095] usb 3-4: Product: Mbox 2
[196181.866097] usb 3-4: Manufacturer: Digidesign
[196185.401670] usb 3-4: Digidesign Mbox 2: 24bit 48kHz

When you say ‘card’ I guess you mean the USB device?

As soon as I plug my Mbox 2 USB cable in, I get a green light on the USB - but you don’t?

Have you tried booting Ubuntu Studio 18 with a USB stick and see if it is the same?

I also tried this on MacBook Pro 2010 (booting USB Ubuntu Studio 18.10) and got the exact same output from dmesg and green lights on the Mbox 2.

(zenseidk) #3

Hi Viktorsmari,
Sorry that I was not clear enough, this post was only a guide to help the next guy with the same problem.
So when someone searches for a solution he/she will find this post.
I have fixed the issue by updating the sound card firmware to version 1.43.

(Viktorsmari) #4

Good thinking!
I hope my addition has improved your posts google-ability :smile:

1 Like