Using an External Duplex Soundcard With Other Applications

(Saam R Sany) #1

Okay so disclaimer, this isn’t actually an Ardour question but the Ubuntu forums seem to be dead nowadays and all the googling in the world isn’t getting me anywhere…

I am specifically using a Focusrite 18i20, but I don’t think that’s the problem. My music production work with Ardour is great, no problems.
But when I am just using a computer for whatever, listening to audio files in Audacious or watching a video, ALSA/pulse will not let me use the Scarlett as my soundcard. In the pulse audio “Volume Control” the only option under the “Output Devices” tab is the “Built-in Audio Analog Stereo” i.e. my internal soundcard. The Scarlett is listed in the “Input Devices” tab, and in the “Configuration” tab I have tried to assign the profile of “Multichannel Output” to see if that made a difference but alas it is the same.

Does anyone use their USB/Firewire soundcard as their normal soundcard using ALSA and if so… help, pretty please? :slight_smile:

(Len) #2

If Ardour is running and using the Focusrite, pulse can’t see it as Ardour locks it for it’s own use. Does the focusrite show up when Ardour is not running (or jack if you use that)?

1 Like
(Saam R Sany) #3

I should have specified, my bad. Even with Ardour shut down, the OS (Ubuntu Studio 15.something) will not recognize the Focusrite as a proper soundcard.

(Len) #4

15.*? ubuntu repo Ardour? other audio applications? That sounds like the era when an application would start jackd for you and it would not stop. So do try:
killall -9 jackd jackdbus
And see if it shows up.

However, it seems to me the kernel tweaks to show focusrite controls may have come after that too. Try a live iso for US from 19.04 or so and see if that makes a difference. If the above line does not work.

(Saam R Sany) #5

I’m on Ubuntu Studio 15.10, kernel version 4.2.0.-42-lowlatency. Trying to kill jackdbus gives me output “No process found” which makes me happy because I am trying to avoid using Jack as a solution if at all possible. The entire first generation Scarlett series has been supported since kernel 3.something, so I don’t think this should be impossible. But you may be right, maybe I just need to update the OS on my recording computer which I’ve been putting off for years hah.

(Len) #6

If you typed the exact line I gave you above and got that response, then jackd was running and holding your card from being accessible from pulse.if you have jackdbus installed (aka jackd2) both the jackdbus and the jackd binaries are installed.
If you are using the Ardour that comes with ubuntustudio 15.10, then you have one of the 4.* series which are considered broken anyway. At the very least DL the Ardour from ardour.org as I don’t think ubuntustudio has an ardour 5.12 that will work with 15.10. There was a time when jackd2 was broken (maybe around that time) such that starting any application that thought it should use jackd would start it for you if it was not already running. That would keep pulse from being able to access your audio device.
there is a ppa for ubuntustudio sw since at least 18.04 that has updated sw in it. I would not go back more than that at this point.

(Saam R Sany) #7

So real quick… I don’t think Ardour is my problem, I had tried to state that in the original post. Sorry it wasn’t clear. For example, I just turned the computer back on and without opening Ardour I went straight for the pulseaudio applet. There is no option to make the Scarlett my “Output Device”.
Secondly, I am using Ardour 5.12, but again Ardour is not the issue here.
ALSA/pulseaudio will not allow me to use the Scarlett as a normal sound card. It recognizes that it is there and that it is a Duplex device, but it won’t let me select it as the only soundcard I want to use. If I open, Ardour (or Audacity or whatever) the Scarlett is working fine with those applications, so the card itself is not a problem.

(Ralf 350) #8

I’m on UbuntuStudio too, I had these problems with my earlier setups but from 16.04 (I think) it finds my soundcard directly.
Now I’m on 18.04 Lts and I recommend that you try that, from a dvd at least.

Ralf

1 Like
(Saam R Sany) #9

Thanks, Ralf. I guess I’ll just have to update and see if that fixes everything. Appreciate both of your help.

(Len) #10

If I understand you correctly, your problem is that you wish the scarlett to be the default device for pulse. Assuming that the scarlett stays plugged in all the time and is plugged in at boot, pavucontrol should let you set this. There are two ways to do this. The normal way, is to select the “Output Devices” tab and set the scarlett as “Fallback”, look for a green check button. The next application to use audio should default to the scarlett. If you want to use it as the only sound card, then choose the “Configuration” tab and set all audio device you don’t want to use to have a “profile” of Off.
I am sorry I misunderstood your question.

(Saam R Sany) #11

Don’t be sorry, I probably wasn’t clear. So what you are outlining is exactly what I am trying to do but:
a) The Scarlett doesn’t get listed in the “Output Devices” tab of pavucontrol.
b) The Scarlett is listed in the “Configuration” tab so I have tried setting it to “Multichannel Output” but it still won’t show in the “Output Devices” tab. I have also turned off the profile for the internal sound card in the “Configuration” tab to see if that was somehow holding back the Scarlett from appearing as an option.