Using a Behringer BCF 2000 with 2.0.2 Isn't Working

Hi, first of all let me congratulate the entire ardour team on a very fine product! I just purchased two BCF2000 units for use with Ardour. The four preset buttons that control the transport work, however when I Ctrl-Button2 click on a control in Ardour to connect it to a control on the BCF2000 nothing happens. I followed the directions in the manual to the letter up until I got to the Midi options which are different now in 2.0.2, so I wasn’t sure how to set those. But, I have tried all possible Midi options as well as played with the different “Remote ID” options under the options menu. I honestly am not sure what those Remote ID options actually mean, so I tried them all. I have searched the internet and tried several possible solutions including some found here on, but to no avail. Any assistance would be greatly appreciated. Does anyone have any ideas on what I should be looking at?

Much thanks in advance,

Take a look at this site how to install new firmware for the BCF2k on Linux, which is (not surprisingly) very easy.

BTW, you did hook up the BCF2k to Ardour in Jack, right?

Greetings Rob de Graaf


I was today in the same situation. I think Bryan had the firmware installed and the MIDI connections in JACK hooked up, otherwise the transport buttons wouldn’t have worked.
Then, in Options/Control Surfaces I selected “Generic MIDI” an “Remote ID assigned by user”. This way the little pop-up window appeared (“operate controller now”) but nothing else happened. Close Ardour, open it again and it worked! (The faders and the mute and solo buttons). Strange, isn’t it?
Nevertheless, when I make ctrl+button2 on the record buttons of the tracks nothing happens. This worked with the previous release. Any ideas?

Best wishes and many thanks to the developers and people who share their knowledge and try to be helpful here. And thanks to Aymeric Mansoux from Goto10 to help me solve this.

Utilizo 64studio 2.0 rc1 y funciona muy bien