USB Audio Lynx LT-USB card configuration

Hi,

I just got a new USB Audio card for my Lynx Aurora 8. So far, I’ve tried to run it in Linux Mint 20 with no luck… I can see it and it does show up in some advanced settings, but configuring it is beyond me.

I have verified that it works with Windows.

AlsaMixer v1.2.2 sees it but gives me a screen that says “This sound device does not have any controls.”

cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7210000 irq 32
1 [Aurora ]: USB-Audio - Lynx Aurora
Lynx Lynx Aurora at usb-0000:00:1a.0-1.1, high speed
2 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xf7080000 irq 17

So far, I’ve modified the /etc/modprobe.d/alsa-base.conf file by commenting out the options snd-usb-audio index=-2 code after following this guide. I still haven’t set device ID in the file.

https://help.ubuntu.com/community/UbuntuStudio/UsbAudioDevices

sudo lsusb -v | less brings up a whole bunch of stuff including device ID, etc. Unfortunately, I’m not exactly sure what to do with it.

usb-devices gives me this output:

T: Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs= 2
P: Vendor=247f ProdID=3227 Rev=10.00
S: Manufacturer=Lynx
S: Product=Lynx Aurora
S: SerialNumber=3204:82193
C: #Ifs= 6 Cfg#= 1 Atr=40 MxPwr=0mA
I: If#=0x0 Alt= 0 #EPs= 1 Cls=01(audio) Sub=01 Prot=20 Driver=snd-usb-audio
I: If#=0x1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=20 Driver=snd-usb-audio
I: If#=0x2 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=20 Driver=snd-usb-audio
I: If#=0x3 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I: If#=0x4 Alt= 0 #EPs= 2 Cls=01(audio) Sub=03 Prot=00 Driver=snd-usb-audio
I: If#=0x5 Alt= 0 #EPs= 0 Cls=fe(app. ) Sub=01 Prot=00 Driver=(none)

I’m not sure why MxCh=0. Perhaps it’s a clue? Where do I edit it and why is it showing up like that?

A friend of mine has an Aurora 16 + LT-USB card. Have you tried updating the firmware of the LT-USB on your windows machine/partition? Beyond that possibility, someone else would have to chime in…

1 Like

The firmware is up to date. I just bought the card.

Fair enough. I mean it was released in April 2011 so I guess it depends on how long it has been sat on a shelf :wink:

1 Like

I walked through the updater and made sure it was up to date.

1 Like

From your posts it is not clear what you did try. I am using Linux Mint 20 (and I do not see that your question is related to Ardour). If you right-click the speaker in the tray, sound preferences, output tab, choose a device for sound output: Can you select your sound card? (Make sure that Jack is not running)

1 Like

I can get audio out of the headphone output from my motherboard. I can see Line Out built in audio and Digital Output built in audio in the sound tab. My card doesn’t show up as a device in Linux Mint sound settings. It does show up in Alsa Mixer though. My question is related to Ardour because I can’t use it if I can’t configure the sound card.

What happens when you open Ardour and select it as the device? Are you able to add inputs to audio tracks?

No. I can’t configure it. It shows up under Alsa, but that’s it.

Try to get sound out of it from terminal with a command like this:

aplay -D plughw:1 somefile.wav

where somefile.wav is any .wav file on your machine.

You can also try accessing it with qjackctl - you should specify the I/O channel count as 8 (Setup->Settings->Advanced->Channel I/O), that sometimes help. This is a better way to test multichannel hardware, system settings (Pulseaudio) sometimes handle multichannel cards badly out of the box.

It would be really nice to have another high end converter functional on Linux (besides Merging and Mytek) and the fact that it is shown in /proc/asound/cards is a good sign. I hope you can work it out!

1 Like

I couldn’t figure out how to play a file on the command line. I’m not sure if I’ve got the hardware named correctly or whatever.

I’ve been tinkering with jack and I can get it to start with the motherboard audio. Here’s what I’ve got so far with the JACK.

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Aurora [Lynx Aurora], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 2: ALC887-VD Alt Analog [ALC887-VD Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Is this the correct way to test? I didn’t understand your earlier post.

https://unix.stackexchange.com/questions/360192/alsa-error-channel-count-2-not-available-for-playback-invalid-argument

I don’t think this is a good sign…

dave@dave-System-Product-Name:~/Downloads$ aplay -D plughw:0 song.wav
Playing WAVE ‘song.wav’ : Signed 24 bit Little Endian in 3bytes, Rate 44100 Hz, Stereo
ALSA lib pcm_params.c:2226:(snd1_pcm_hw_refine_slave) Slave PCM not usable
aplay: set_params:1314: Broken configuration for this PCM: no configurations available

dave@dave-System-Product-Name:~/Downloads$ aplay -D plughw:0,0 song.wav
Playing WAVE ‘song.wav’ : Signed 24 bit Little Endian in 3bytes, Rate 44100 Hz, Stereo
ALSA lib pcm_params.c:2226:(snd1_pcm_hw_refine_slave) Slave PCM not usable
aplay: set_params:1314: Broken configuration for this PCM: no configurations available

dave@dave-System-Product-Name:~/Downloads$ aplay -D plughw:0,0 song.wav
Playing WAVE ‘song.wav’ : Signed 24 bit Little Endian in 3bytes, Rate 44100 Hz, Stereo
ALSA lib pcm_params.c:2226:(snd1_pcm_hw_refine_slave) Slave PCM not usable
aplay: set_params:1314: Broken configuration for this PCM: no configurations available

dave@dave-System-Product-Name:~/Downloads$ aplay -D hw:0,0 song.wav
Playing WAVE ‘song.wav’ : Signed 24 bit Little Endian in 3bytes, Rate 44100 Hz, Stereo
aplay: set_params:1314: Broken configuration for this PCM: no configurations available