Upgrading from version 2.3 to version 2.4.1

Hi! Does anybody know how to upgrade from Ardour version 2.3 to version 2.4.1? I am new to Linux and only really know how to install software via add/remove. I cannot find an oprion in there to upgrade. I have already downloaded the file.

Thanks in advance

You can’t use package managers to upgrade to Ardour 2.4.1 unless your package manager repositories have 2.4.1. Most currently do not. It would be nice if they kept more up to date, but thats not something that the Ardour development team can control.

debian sid does have it. If you use debian, just upgrade to “unstable”.

As he said in a previous post, Ben is using Ubuntu Studio.
Ben, which file are you referring to?
There are two ways of installing an application, either you compile from source and install it or you just install the binary package. Ardour doesn’t distribute binary packages for Linux systems. The distros’ maintainers are who prepare them and get them ready to install in your system.

You can install the packages by means of a so-called package manager, like synaptic. Your distro has official repositories where there is a collection of packages and from where they are ready to download and install with a mouse click.
If the official repositories of Ubuntu hasn’t yet ardour 2.4.1, then there are turnarounds you can use.

I suggest you read this thread and post there if you are in doubt:

By the way, the last official versions of ardour are in 64Studio testing just 3 or 4 days since the release.


This is my step by step on a fresh UbuntuStudio 8.04 install (will also work with Kubuntu).

  1. Download source code and untar to ’/home/[your user name]/dls’
  2. Download the VST SDK (google vst sdk and look for the link that starts with ygrabit.steinberg…) Make sure to get the 2.3 version. (selected after agreeing to license terms IIRC)
  3. Place the entire sdk zip file in ’/home/[your user name]/dls/ardour-2.1.4/libs/fst’
  4. from terminal enter:

    sudo apt-get remove ardour
    sudo apt-get install build-essential
  5. Install needed tools and build dependencies. Enter in
    terminal (all one line):

    sudo apt-get install -y scons libtool pkg-config gettext libjack-dev
    libasound2-dev qjackctl libxml2-dev libsamplerate-dev libraptor-dev
    liblrdf-dev libgnomecanvas2-dev libboost-dev liblo-dev libglib-dev
    libgtkmm-dev libsndfile-dev wine-dev fftw3-dev automake
  6. compile and install. Enter in terminal (individual lines):

    cd /home/[your user name]/dls/ardour-2.4.1
    scons VST=1
    sudo scons install
  7. start jack with qjackctl and run ardourvst

Place VST plugin .dlls into /usr/local/lib/vst folder.

I hope this helps, but I can’t take complete credit for this…I found a guide online from somewhere (don’t know the source), changed a few things, and this is what I ended up with…hopefully there are no typos, but if something doesn’t work, let me know and I’ll take a look…


Thanks once again for your help musicman. You are the Ardour guru.

this is what happened after scons VST=1

ben@ubuntu:~/dls/ardour-2.4.1$ scons VST=1
scons: Reading SConscript files …
Are you building Ardour for personal use (rather than distribution to others)? [no]: y
OK, VST support will be enabled
Checking for pkg-config version >= 0.8.0… yes
Checking for gthread-2.0… no
gthread-2.0 >= 2.10.1 not found.
You do not have the necessary dependencies required to build ardour
Please consult http://ardour.org/building for more information

where do i get gthread?


I’ve written a guide to installing on Ubuntu Studio here;


I’ve also written a couple of simple shell scripts to install and update Ardour. They should work fine. There’s also a video showing how to run them. You can download them from here;



far from being a guru…I still consider myself a linux newbie!

Anyway, did you install the build-essential package? Also, make sure that the system is updated prior to compiling…I haven’t ever run into that dependency problem…also, try installing libglib2.0-dev…(sudo apt-get install libglib2.0-dev)…let me know if none of these work for you…


P.S. I’m not here too often, so if you need to, feel free to email me at steve -at- south county church . com (obviously, all one word…)