Upgrade problem installing 6.9

I had earlier put 6.9 fresh on a newer machine (now in the shop) so upgrading from 5 to 6.9 on my backup laptop has never happened until now. It was a very…slow…install, something like two hours. And at the very end I get a failure message that “invalid characters” killed the install. That’s all I have. The specific file I was running was: Ardour-6.9.0-x86_64-gcc5.run.This is on Ubuntu 18.04 LTS as the OS. Existing 5 install works fine, so I don’t understand what happened. Any ideas?

That “invalid characters” message might indicate that the file had errors after download. Have you tried downloading the installer again, and either just run the new copy, or diff the original copy against the new to see if the original is different?

Tried it again today, on a different machine, without any other Ardour or actually any other files, on a different OS, Linux Ubuntu 20.04.02 LTS, with the same result.

I see something called X11 is required but have no idea what it is.

It was running the script with a UTF-8 encoding, which ought to be fine. But I wonder if it should be some other encoding.

For the record this is Ardour 6.9 X64 for AMD 64 and Linux. I downloaded it from the Downloads folder of the site, and ran it (Ardour-6.9.0-x86_64-gcc5.run) directly from my local Downloads folder. I didn’t see any other download on the site that looked appropriate. By the way, since this is the second time, I tried to start a case in the tracker…but I coudln’t log in to the tracker!

UPDATE: RESOLVED!
I am the OP and my problem has resolved. As much as I want to simply close this issue and/or delete the post, I am going to explain what happened so that 1.) others can avoid my fate, and 2.) if the amazing and hard-working Paul Davis ever needs a laugh, he might find amusement in my story.

What I did:
I downloaded the file as noted. It stayed in my Downloads folder. I right-clicked it into Properties and checked the box to make it runnable. Then I double-clicked the file to run it. Which it did.

All 900,000 + lines.
One at a time.
In the text editor.

I did not look at the file “if you are doing this for the first time in Linux” because I am NOT a first-timer. I’ve installed lots of software from Terminal. I just…forgot. But I combed through through the instructions after my failures and thought I should at least look at the first-time document. In there I found “How to Install.” And in that was the example of involking the .run file from the terminal window.

uh-oh.

I then quite sheepishly opened a terminal window, followed the instructions, and installed Ardour. Everything is fine now. I’m very embarrased. At least I didn’t open a bug in Mantis over this.

By way of explanation, I just got this machine back from the factory after weeks of dealing with a tech issue. I was very tired. But don’t do what I did, son, find your own path, and here are my final words of wisdom: RTFM.

4 Likes