Updated Ubuntu Studio to 21.04 now Ardour crashes

I have been using Ardour for about 4 months to edit a weekly podcast. Once I learned how it all worked, it has been AMAZING and worked flawlessly.

I recently updated Ubuntu Studio to 21.04 with little thought. Tonight I tried to edit this week’s podcast, which is actually a Snapshot from the last edit, and Ardour keeps crashing.

We record every 2 weeks and then I make 2 podcasts from that one recording. Tonight’s edit is largely setup, just a few things here and there and it’ll be done, but I can’t get Ardour to open EXCEPT if I uncheck real time scheduling in qJackCTL.

I read that as a solution somewhere online, but I don’t know why it works. I am able to open the podcast and edit it, but what is real time scheduling and why is this breaking now?

I feel like when I started using Ardour I had to add my user to the audio group with real time privileges, maybe with the update, that got wiped out. I don’t remember how to do it. Does that sound like the thing that could be breaking it all?

Additionally, since I contribute, I have been using the latest version of Ardour, 6.6. Now I notice that Ardour 6.6 is in the repo for Ubuntu Studio 21.04. Could that version be causing a conflict with the version of 6.6 I have been using?

I’ve been using Linux for about a year and am no expert, so I’m a little stumped on how to proceed.

Any ideas?

Here are 2 error messages I received that might help explain what is happening.

Thanks for any insights you can offer.
Screenshot_20210426_173043
Screenshot_20210426_171909

The two errors are caused by you not following the instructions for installing JACK, or by Ubuntu not doing the right thing.

You still need to do this, apparently.

Also, unless you actually need JACK for some specific reason, we recommend that most people avoid using it, and simply use the builtin ALSA backend (in Ardour)

1 Like

Also, installs of Ardour from ardour.org never conflict with those from your Linux distribution. However, we cannot support the versions from distributions, because we do not control the build process. The versions from ardour.org get installed into /opt and can even be parallel installed with each other (e.g. 5.12 and 6.6)

1 Like

The release notes of Ub Studio 21.04 read “Ardour has been upgraded to version 6.6 and is a git snapshot of the upcoming 6.7. We will release the final version of Ardour 6.7 when it is ready.”

1 Like

That is great news! 6.6.0 had various issues and I suggested it to the packages to use a recent git version to avoid those.

1 Like

I went back and forth between using and not using Jack when I got started with Ardour. Now I finally have it all working so I got used to it. I got it working again. The audio configuration file was disabled so I copied it, enabled it, and deleted the old file. I opened Studio Tools instead of just qJackctl and it looked like it no longer had my Focusrite Scarlett Solo USB input selected so I changed that. I did one other thing as well and then it all worked again.

I think the main reason I keep soldiering on with Jack is that soon I want to livestream over OBS and it seems like Jack is the way to do that with multiple inputs and playbacks. At least now I kinda know where the controls are, even if I don’t really need it to edit the weekly podcast.

Good to know. I don’t always understand where software gets installed in this day and age of universal package formats. I have a folder in my /home called appimages and I put all my appimages there, but when I download files, normally deb packages, I don’t know where they go after installation. When I download Ardour directly, is that a deb package?

In the future, should I remove the repo version or does it not matter? I plan to contribute to ARdour for awhile, I love it. It solved all the pain points Audacity gave me while editing a podcast.

Is there a benefit to using the repo version over a directly downloaded version of Ardour? Some say repo is tuned to work best with your distro. I don’t always need the latest and greatest, but sometimes I’ve had plugin problems that seemed to be fixed by using a different version.

As far as we know, there are no Linux distributions that build Ardour with the patches we apply to various 3rd party libraries. So in this sense, we would consider all the distribution-provided versions to be inferior to ours. We also often have to say “no” to providing help & support for the distribution version (though we try not to do that).

offtopic: Come on guys (and girls, still not too many)! Unless you are living in an emerging country, why don’t you just subscribe or at least send over that specific amount to get a license code for one or two major versions, once you think Ardour is the right tool for your work. Please, let’s support this brilliant team so we all get new versions and perfect support in the future! Thanks

2 Likes

I do contribute, each month, automatically, and will continue to do so, as long as I use Ardour. Not sure why you posted this here.

I guess I’ll have to figure out the way to make sure the version I open is the version I get directly from Ardour as opposed to the repo version.

Also, unless you actually need JACK for some specific reason, we recommend that most people avoid using it, and simply use the builtin ALSA backend (in Ardour)

May it be a good idea to update the installer notes, then? When installing Ardour 6.6.0 in Linux, a message is shown to suggest installing Jack if it’s not present:

Checking to see if Jack is installed

The program Jack is missing from this system.

Jack is a very useful utility to allow you to interconnect Ardour and other audio/MIDI applications.
You can use Ardour without it, but you may find it useful to have around.

Install jack using system software repository? [y/n]:

Also don’t think this is appropriate to say here. How people choose (or are able) to support Ardour, financially or otherwise, is their business and their business alone. That’s before we even talk about the financial damage caused by the pandemic.

1 Like