Unreadable/invisible fonts in 3.0beta5


I have white fonts on white background in several areas of A3. Affected are the lists in the browsers to the right of the editor (Regions, Tracks etc) and in the similar boxes to the left in the Mixer (Tracks, Groups).

here is a screenshot:

I had this problem before and Paul suggested, that it could be caused by KDE. Now I tried running in Fluxbox and XFCE – both to no avail.

I cannot find respective entries in the theme manager. The situation improves a bit with the light-theme but the aesthetics of the light theme are absolutely not my cup of coffee, BTW the colors in the light theme do not fit the colors in the bitmaps for buttons etc…

So how can I cope with that? Is there a file, I can edit to make the fonts/background appeare in reasonable colors?

Hello zettberlin and nowhiskey,

~/.config/ardour3 does not have anything to do with it.

I’ve seen this behaviour since a long time now and I believe it’s buried deeply somewhere in KDE’s oxygen-gtk theme engine. change that to use Clearlooks for GTK apps and the problem goes away.

The binary bundles from ardour.org are not affected, as they use the bundled Clearlook engine.


The binary bundles are affected unless the b5 is not one such bundle. It hasn’t been around for a long time for me either, it worked just fine last summer before I jumped ship to Ubuntu Studio (I was using KDE), on my computer it appeared about two months ago - although this is outside of KDE, on KDE it probably would have started sooner.

The problem is two-fold and thankfully has nothing to do with Oxygen which is my preferred engine in and out of KDE:

1.- KDE's internal mechanism for setting the system colors

I believe this is what Paul is talking about, it affects only KDE users and there's probably no way to fix it without patching KDE itself. I'm not absolutely sure about what mechanism KDE uses to set the colors but maybe ~/.kde/share/config/gtkrc which starts with the following comment:
# If you do not want KDE to override your GTK settings, select # Appearance -> Colors in the System Settings and disable the checkbox # "Apply colors to non-KDE4 applications"

…but that was the first thing I tried and it didn’t work.

2.- The mechanism of the GTK configuration module on KDE's System Settings

This is not present on every system but when it's present it affects the whole system, not only KDE. On Xfce (for example) it appears to cause complex graphical failures if it's settings are different from Xfce's own. The solution is to uninstall the module from your package manager and delete the .gtkrc-2.0 file and the .gtkrc-2.0-kde4 symlink that are in your Home folder. Those files are not used by the other desktop environments.

It costed me a whole day of fumbling around but I’m now happily using the Oxygen theme in Enlightenment without any problem to report, ironically the biggest PITA was writting this message:

I sorted it out on the same day it happened (can’t work without groups), I should have posted about it but it didn’t occur to me that other people could be having the problem, thought it was a glitch of my computer.

Better late than never no?

hallo z,


~$ rm .config/ardour3


and than restart in fluxbox / xfce…



So short version, KDE and Gnome broken use e17:)


/e17 user flees

Ok so it is caused by by some stupid “function” of KDE and it is not fixed by running A3 in XFCE or Fluxbox…

So KDE seems to do something persistent such as changing a config-file…
Is there a way to revert the changes, KDE seems to inflict on Ardours configuration?

This is caused by KDE. We do not intend to try to fix it. KDE overrides application theme preferences, which I consider unacceptable. Of course, if someone finds a fix for this that doesn’t involve doing something stupid, I will happily use it.

I think I missed something. “The solution is to uninstall the module from your package manager”
I read through the posting a couple of times and can’t see what module name is being referenced that should be removed.
I don’t have this problem at the moment, but would like to avoid doing something that makes it show up.
The .gtkrc-2.0-kde4 file in my home directory is not symlinked, it is a real file with a note that it was written by KDE control center.