Understanding grid mode rulers

There’s something that I just don’t understand about the visual rules/guides when activating Grid Mode.
If I choose “Bar” as Grid Mode, then a ruler is drawn for every bar along the timeline, so far so good:


But if I choose “1/4 Note” as Grid Mode, there is not drawn a ruler for every 1/4th note along the timeline. Instead, it seems like for every third 1/4th note in a bar, there is no ruler drawn:

Why is that? I’m pretty sure rulers was drawn for every 1/4th note in Ardour 5?

Zoom in. Ardour 6 avoid drawing too dense grid-lines.

I’d say I’m zoomed pretty far in at this point:


I can zoom even further, with no ruler appearing.
Is there any way I can customize the density? Who’s to say what’s too dense?

Actually the 1/4 note gridlines are there in your 2nd screenshot and also the ones on the zoomed-in screenshot.

Yes, Preferences > Editor > Snap > Approximate Grid/Ruler granularity (pixels).

The default is 25 pixels difference between each grid/snap point. Which is a reasonable mouse-move distance.

Are you refering to the indicators on the Bars & Beats ruler line itself? They are there indeed, but there are no vertical line drawn across the editor from every third 1/4th note in the bar. Which is what I’m after, as a visual guide.

I’d say it has to do with your theme template? maybe trying the default has all the lines shown.

2 Likes

You’re right! I’m using the Clear Gray color theme. When changing to a different theme, the lines appear.
Is there any way to modify this in the color theme template?

Edit: turns out I must have changed something I shouldn’t have in the color profile, as Restore Defaults made the ruler lines appear again

You can modify these lines through:

Preferences>Appearance>Colors>Items

grid line major
grid line micro
grid line minor

1 Like