Unable to save preset for calf multiband compressor

i created a preset for the calf multiband compressor and saved it, and i am able to load it again in the same session, but once i close and reopen ardour and create a new session, the preset is gone. i’m using ardour 6.7 on ubuntu studio 20.10

figured it out. ardour was saving my lv2 presets to the .lv2 folder in my home directory (i.e., /home/autumn/.lv2) and not /usr/lib/lv2/. once i reopen ardour, it doesn’t scan this location because it isn’t in the scanning list, and it wasn’t set as my LV2_PATH

ardour should either add the lv2 home dir or allow you to add it yourself. setting the LV2_PATH is just too much work tbh

Ardour from ardour.org is built with this compile-time flag:

--default-lv2-path='~/.lv2:/usr/local/lib/lv2:/usr/local/lib64/lv2:/usr/lib/lv2:/usr/lib64/lv2'

That includes ~/.lv2 (in your case /home/autumn/lv2.

We cannot control what happens with distro builds (which is why we generally can’t support them).

1 Like

ah ok, i don’t remember if i’m using a distro build or not but thank you for the info! i’ll have to buy ardour and support you all!

This is correct. It is the default place for LV2 user-presets according to the LV2 spec:

https://lv2plug.in/pages/filesystem-hierarchy-standard.html

1 Like

that’s correct. A regular user could not even write to a system folder such as /usr (no permission). Only the superuser (root) can. While you might be the only user on your machine, Linux is multi-user. In a multi-user environment, each user needs his own settings, presets, etc. That’s just one of the many good reason why regular users do not have write permission on system folders, and all of their “personal” stuff must go into their own home directories.

Fix your PATHs. :wink: