Unable to run on Windows 11

version: 7.4.0
system: Windows 11 21H2 22000.1880
cpu: AMD Ryzen 7 5800H with Radeon Graphics 3.20 GHz

When I double-click Ardour.exe, there is no response, and the program automatically quits.
And “C:\Users<user>\AppData\Local\Ardour7\CrashLog” directory is empty.

Starting with the console and outputting: ARDOUR_DATA_PATH not set in environment
Ardour 7.4.0: Setting up the session in the home directory via ARDOUR_CONFIG_PATH
Audio-midi engine setup failed.

I’ve just tried and the hard part was to install it (since the installer is not signed):

→ More Info

→ Run Anyway

The normal installer runs and after that Ardour 7.4 starts just fine on Windows 11 (I’ve used the task-bar at the bottom of the screen to launch it):

I am using a Chinese system.
I have also tested it on a virtual machine (Windows 10 Chinese version), but it still failed to open.
Then I tested it on Windows 10 English version, and the program started running.

So the issue seems to be related to the operating system language, as the Chinese system is unable to run it. I’m not sure if the same problem would occur with Japanese or Korean systems.

Good find. Thank you for the feedback (in case someone else comes across this).

Not too long ago someone provide a Chinese translation of Ardour, so at least to them it apparently worked. Sadly I do not know can not test this myself, nor know how good the translation is: ardour/zh.po at master · Ardour/ardour · GitHub

In Ardour you can disable translations in Preferences > Appearance > Translations

Sadly in your case that won’t work since you cannot start it. However you can force translations off by creating an empty file: %localappdata%\Ardour7\.translate


I created a “.translate” file, and now the program runs successfully! Thank you!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.