Unable to record from PulseAudio

I want to record a track from PulseAudio under Linux x86-64 using the Ubuntu-provided Ardour 6.9.0~ds0. This works perfectly with Audacity, for example, but I want the track directly in Ardour. I’ve setup my hardware, but when I start the recording a new track appears (“Take-xyz”) but it is perfectly silent, a complete flatline.

Previously I had no real-time permissions enabled, which showed a warning, but the error (recording only silence) persists even when those RT permissions are enabled.

I absolutely do not want to use/install Jack and I’ve also tried the ALSA backend, at which neither playback nor recording works for me.

Any help appreciated,
Thanks, Kev

Sure, a sound-file editor does not care about alignment, nor if the underlying settings or latency changes. For a DAW like Ardour however this is not an option. Ardour’s Pulseaudio backend is playback only, and not intended to be used except for some casual listening on the road.

New permissions are only applied at login. Have you re-logged in (or rebooted) since you have enabled them?

Likely because the soundcard was in use by some other application (likely pulseaudio),
or perhaps because connections in Ardour’s Mixer are not present (since you’ve used pulseaudio).

Let’s try to get to the bottom of this:

While Ardour is running and uses the ALSA backend, please open a Terminal window and run the following command:

cd /tmp && wget https://community.ardour.org/files/adevices.sh && bash ./adevices.sh

It will not modify your system; it lists all soundcards, their current settings and applications using them, etc. Then copy+paste all the output of that script here.

Sure, a sound-file editor does not care about alignment, nor if the underlying settings or latency changes. For a DAW like Ardour however this is not an option. Ardour’s Pulseaudio backend is playback only, and not intended to be used except for some casual listening on the road.

Alright, then at the very least this is a confusing UI to let me start a recording with a NULL source. I indeed do not care about alignment nor latency.

New permissions are only applied at login. Have you re-logged in (or rebooted) since you have enabled them?

Yes, they’re all there.

Likely because the soundcard was in use by some other application (likely pulseaudio),
or perhaps because connections in Ardour’s Mixer are not present (since you’ve used pulseaudio).

The latter seems to be the case because when I start a new project using ALSA, it does indeed work. Except that I then have a monitoring output on that I can’t figure out how to turn off as soon as I arm the track. I’ll poke around and try to see what I need to change in my Pulseaudio project to make it work with ALSA. Thanks!

EDIT: Montoring can be disabled by Edit → Preferences → Monitoring → Record monitoring handled by: audio hardware