Unable to locate "armfh bundle" when installing on PI4

Downloaded the file “Ardour_arm64-6.3.0.run” and got the message:
Verifying archive integrity… 100% All good.
Uncompressing Ardour 100%

Welcome to the Ardour installer

Ardour will be installed for user pi in /opt

Wed 18 Nov 2020 07:15:15 PM EST
Architecture is armhf

!!! ERROR !!! Can’t locate armhf bundle file.
The installer detected the system as armhf, but this bundle
does not contain the files needed for that configuration.

Press ENTER to exit installer:

For the RPi with Raspbian you need the 32bit version (not the 64bit one):
download Ardour_armhf-6.3.0.run instead.

While the processor is 64bit capable, the default System on the RPI is still 32bit (32bit ARM with hardware floating point support aka. armhf).

Thank you. Looks like I downloaded the wrong one. Tried to download the right one, but It looks like I have to pay again. Is that right?

Visit https://community.ardour.org/download proceed to “Yes, I want Ardour 6.3 for GNU/Linux ARM 32 bit”

…and when reaching payment choice use the right-most one “Change platforms”:
image

Thanks! Problem solved!