Unable to import .ogg files

I’m just coming from Ardour 5 to this latest version so I may not be aware of all that’s changed. It working great so far. There are certain quick little projects where I’m looking to save some memory on my computer and I just work with .ogg. I tend to use .ogg a lot, for this that reason.

On this new version, at the import dialogue the option for copying files to session is enabled and greyed out for .ogg files. After I import, I find that Ardour has concerted the file to .wav and moved it into the session folder. What I would prefer is to import and use the .ogg files as they are, where they are, to save space, unless it’s absolutely necessary to do otherwise.

Is there some setting to change for it to work like before.

We changed this back in 2019 because lossily-compressed formats such as mp3 or ogg/vorbis do not allow us to “seek” precisely to a sample position in the file. This can cause problems for playback because we are not properly aligned across tracks. It was always a problem, but it didn’t get noticed for some time.

I see. I never really noticed myself. Sounds like a good call. I guess, for some reason I imagined and expected .ogg to work perfectly on a Linux computer, didn’t think about it too much. .wav it is then. Thanks for the reply.