Unable to import audio

I just installed Ardour 2.8.7, revision 6628 on Gentoo and I get this when trying to import audio:

[INFO]: Loading session /home/audiodef/ardourtest using snapshot ardourtest (2) Loading history from '/home/audiodef/ardourtest/ardourtest.history'. [ERROR]: SndFileSource: cannot open file "/home/audiodef/ardourtest/interchange/ardourtest/audiofiles/Bullet In My Brain, SN_Intro Str, Mix (167)-c1.wav" for read+write (Error : major format is 0.) [ERROR]: Unable to create file /home/audiodef/ardourtest/interchange/ardourtest/audiofiles/Bullet In My Brain, SN_Intro Str, Mix (167)-c1.wav during import [ERROR]: SndFileSource: cannot open file "/home/audiodef/ardourtest/interchange/ardourtest/audiofiles/Bullet In My Brain, SN_Intro Str, Mix (167)-c1.wav" for read+write (Error : major format is 0.) [ERROR]: Unable to create file /home/audiodef/ardourtest/interchange/ardourtest/audiofiles/Bullet In My Brain, SN_Intro Str, Mix (167)-c1.wav during import

I’m afraid its not possible for us to provide for Gentoo ebuilds. There are too many variables to consider/control. The error you’re reporting has not been reported by any other user and/or builder of Ardour. I’m sorry that you’re having difficulty with it, but because of the way Gentoo works, there’s really nothing I can do. You would need someone with debugging skills to work closely with you to find out what the problem is, and unless you’re an Ardour subscriber, I can’t offer that help.

Your problems with ardour3 appear to come from the tact that you tried to install it. This is not supported at this time.

I suspect Paul is correct for many reasons, but I will say based off the sndfile-info output I would suspect a problem with your build of Ardour in particular. I would recommend building it yourself, in other words don’t use the ebuilds, but download the source yourself and build it. You will then be able to test without installing via the ardev script in the source directory structure. Since you have already built via portage this shouldn’t be difficult, but go ahead and remove the portage version all together for testing purposes.

Are you using the pro-audio overlay or no?


By the way, Gentoo’s ebuilds in their standard portage have an option hardcoded in that is not reccomended for compiling Ardour2, namely it forces it compiled with SYSLIBS=1. This is not recommended. The ProAudio overlay in at least some of the packages has this as a USE flag instead, but going off memory since the wiki for it is down right now, I believe it is enabled by default on those packages.

Things like this are why support isn’t really offered for distribution packages from Ardour’s team.


The ebuild is broken. They will have to fix it. The limitations on distributing ardour with VST support no longer exist (they have not existed for a couple of years). Moreover, the way that they implemented the limitation for the “old days” is wrong unless they first asked you to confirm that the build was for your personal use.

As for Ardour3, no distribution, including Gentoo, should have made this available and I have requested this several times in the past. It doesn’t matter to me that Gentoo manages to pull it from SVN. Ardour3 sometimes has a dozen commits per day, and we continue to feel free to totally break existing sessions created with it. Nobody should be using this as if its just another ebuild.

I’m sorry, but I’ve had it with Gentoo.

@audiodef: as discussed the other day on IRC, this is a build error in either libsndfile or ardour, specific to your system. i am more or less certain of that.

I just recompiled libsndfile. No change. I’m upgrading 2.8.7 to 2.9999 to see what happens.

Btw, I also have 3.9999 in its own slot and this is what I get when I try to start it:

WARNING: Could not check your glib-2.0 for mutex locking atomic operations.

/usr/bin/ardour3: line 39: /usr/lib/ardour3/ardour-3.0: No such file or directory
/usr/bin/ardour3: line 39: exec: /usr/lib/ardour3/ardour-3.0: cannot execute: No such file or directory

Seablade, this is the sndfile-info, although Paul probably gave me what I need to know.

Version : libsndfile-1.0.21

File : Bullet In My Brain, SN_Intro Str, Mix (167).wav
Length : 6272512
RIFF : 6272504
fmt : 18
Format : 0x1 => WAVE_FORMAT_PCM
Channels : 2
Sample Rate : 44100
Block Align : 4
Bit Width : 16
Bytes/sec : 176400
PAD : 4042
data : 6268416

Sample Rate : 44100
Frames : 1567104
Channels : 2
Format : 0x00010002
Sections : 1
Seekable : TRUE
Duration : 00:00:35.535
Signal Max : 19836 (-4.36 dB)

Here’s the output of Portage. I know, you don’t support Portage, but if I can pinpoint the error, maybe I can figure out how to fix it for Portage.

>>> Emerging (1 of 1) media-sound/ardour-2.9999 from proaudio * CPV: media-sound/ardour-2.9999 * REPO: proaudio * USE: elibc_glibc freesound kernel_linux lv2 nls sse userland_GNU vst x86 * this ebuild fetches from the svn maintaince * ardour-2.X branch >>> Unpacking source... /var/tmp/portage/media-sound/ardour-2.9999/temp/environment: line 3004: agree_vst: command not found * ERROR: media-sound/ardour-2.9999 failed: * you can not distribute ardour with vst support * * Call stack: * ebuild.sh, line 47: Called src_unpack * environment, line 3004: Called die * The specific snippet of code: * agree_vst || die "you can not distribute ardour with vst support"; * * If you need support, post the output of 'emerge --info =media-sound/ardour-2.9999', * the complete build log and the output of 'emerge -pqv =media-sound/ardour-2.9999'. * This ebuild is from an overlay named 'proaudio': '/var/lib/layman/pro-audio/' * The complete build log is located at '/var/tmp/portage/media-sound/ardour-2.9999/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/media-sound/ardour-2.9999/temp/environment'. * S: '/var/tmp/portage/media-sound/ardour-2.9999/work/ardour2'

By the way, I maintain an audio on Gentoo guide. I mention Ardour in it, and in particular, mention that 3.9999 is not for production use. Could you take a look at it and tell me if you prefer I reference 3.9999 and you in a different way? Just search for your name, skipping over the other stuff unless you want to read it. Just want to make sure I give the proper respect. :wink:


Post the output of sndfile-info on the files you are trying to import?


I’ll change my guide to state that Ardour 3 simply should not be used and that the author of Ardour has requested that it not even be in Portage or even any overlays. Thanks for explaining your side to me. I completely understand.

I’m sorry you’ve had it with Gentoo. It’s not the easiest of distros and the maintainers can be pretty obtuse sometimes. Speaking for myself, I don’t bother filing bug reports on bugs.gentoo.org. I either fix it myself or find some other workaround (downgrade, upgrade, manual compile, etc.). I’ve tried Ubuntu now and then but the last time I did, I couldn’t even find gscanbus! Ubuntu is still very nice, though, and I recommend it to all my less-technically-inclined friends.

I think I have to apologise for being premature about my last post. Had I read the portage output more carefully, I would have realised the ebuild is an easy fix: just take out the three lines that refuse to proceed if the vst use flag is selected.

I'm sorry, but I've had it with Gentoo.

Heh Gentoo itself isn’t bad, but package maintainence in general is an issue you and I have gone through many times over the years and will likely never go away sadly.


By the way, why will version 2.8.11 not compile with the vst option?

I think I’ll just be happy with the pro-audio version. I love Gentoo, but some of the devs can be pretty hard-headed. :stuck_out_tongue:

why will version 2.8.11 not compile with the vst option?

what is the error? there is no reason why it should not …

There is an entire debate that has been had many times about SYSLIBS etc. Ill leave it at that, though some googling will likely get you some more information.

By the way, make sure you report that issue to the Gentoo Portage package maintainer. There is absolutely nothing that the Ardour team can do to fix it since noone else seems to have that problem, it appears to be something specific with the Gentoo package.


2.9999 is from the pro-audio overlay and it does have sys-libs as a use flag, and it is disabled by default. And running it (2.8.11) shows it doesn’t have this import problem.

I have to wonder why the main tree maintainers didn’t put the sys-libs use flag in for their package, but I’m glad the pro-audio maintainers caught it.