Unable to Export Audio

Hi all,

I’m running Ardour v 6.9 (latest download) on Ubuntu Studio 20.04. I’ve been working on a number of different sessions and, all of a sudden, find myself unable to export audio in any of them. Previously, this had worked without a hitch.

I’ve tried exporting to redbook, mp3, ogg and flac to no avail. The progress marker does not move through the file and the progress indicator does not progress past 0%.

If I tick the ‘realtime’ box, the session will ‘export’ successfully, but now gets stuck on the ‘encoding’ stage.

**EDIT. I am using JACK. If I switch to Pulseaudio, export works OK. Still, it’s odd that that suddenly stopped working under jack… **

Am I doing something daft?

Thanks for any and all help!

And in fact, the pulse audio workaround is cumbersome because all tracks become disconnected from the master bus and have to be manually reconnected.

Am I the only one who’s encountered this?

Check your version of Jack.

There were older versions of Jack that suffered from bugs that caused issues like this.

 Seablade

Also recent versions of jack2 cannot properly switch from/to freewheel export in some cases. Some users reported issues when the jack/pulse bridge was loaded.

Thanks! I shall. I did spot those posts from 2016 on the forum but assumed that it couldn’t still be an issue.

Well it just depends on your version, what I was referring to was fixed since then but many distributions don’t update quickly if at all until their next version, but as @x42 mentioned there is a new bug in the most recent versions as well apparently.

  Seablade

Thanks. I seem to be running 1.9.12~dfsg-2ubuntu2. I know that the latest is 1.9.17 but perhaps I’ll wait for the distro update rather than try to build it myself.

I really appreciate the help. Thanks!

Is there a specific reason why you want or need JACK?

If not, you’re much better off without it, prefer to use Ardour’s ALSA backend directly.

Great question. Selecting ALSA as the audio system under Audio/Midi Setup in Ardour and hitting start

a) crashes ardour if jack is not running and I select my focusrite 2i2 as the input/output device
b) gives a cannot start message if jack is running and I select my focusrite 2i2 as the input/output device
c) gives a different cannot start message if jack is not running and I select no input/output device.

I have not investigated this bug yet however.

You need to stop jackd first.

Also make sure you use Audio System: ALSA (not Audio System JACK, with driver ALSA) .