Unable to create port error

(Ncldjr2) #1

Hi all. I’m running Ubuntu Studio 18.10. In Ardour, when I close a project then try to open another one, I get an error message that says “unable to create port: failed constructor. Click the Close button and try again”. The only way for me to open another project is to close then reopen Ardour. I tried deleting the instant.xml files, but that did not seem to help. No control surfaces are checked. I think that Ardour is set to handle many more tracks than I have. I have also exported the projects as archives, and imported them into Ubuntu Studio 18.10 on VirtualBox, and I don’t seem to have the same problem. Would completely uninstalling Ardour, then reinstalling help? I wonder if I installed an app that is interfering somehow with Ardour. Any suggestions as to how to fix this?

(Paul Davis) #2

What version of Ardour? What audio/MIDI backend are you using (JACK?)

(Ncldjr2) #3

Ardour 5.12,.0-3. I’m connecting to Jack, though it does the same thing if I connect to ALSA.

(Paul Davis) #4

Can you open the failing session if you quit ardour and load it in a new instance?

(Ncldjr2) #5

If I close Ardour, I can open any session. However, I cannot even close a project and reopen it. In addition, it does not matter which project I open first. I cannot load any other project without closing Ardour. I just tried to reinstall Ardour (without uninstalling it) but that did not help.