Unable to connect sources/sinks from Ardour, no problem in qjackctl/patchage

Hi all,

I’m just getting my feet wet with ardour4 and I’m having a bizarre problem that I don’t see mentioned online. I’m using version 4.6.22 from kxstudio in ubuntu 15.10.

Everything seems to work OK, but busses aren’t autoconnecting on creation (I checked the option is properly set), nor can I establish/remove any connections using either the Audio Connection Manager or the ‘disconnect all’ menu options, or the partial patchbays in the bus options. The green dot is shown while I click the mouse, but it disappears on releasing.

However, any changes made by external means (qjackctl or patchage, for example) are immediately seen in ardour (and they work too).

It’s mostly bothersome because of the autoconnections not working. Any ideas on how to tackle this? I’ve tried starting jack manually before launching ardour, and letting ardour to start it with same results.

Thanks in advance.

You haven’t stated which audio/MIDI backend you’re using, but it sounds like JACK. I suggest you try using the ALSA backend (though you may need to stop PulseAudio manually first). I suspect you may have a JACK version that prevents self-connection.

Yes, it is jack, sorry, and with alsa as backend it works. But I haven’t managed to use alsa with two different sound cards (ardour complains about invalid device when trying to start alsa), so I was trying jack with alsa_in. Incidentally, the jack version is

$ wajig policy jackd2
Installed: 2:1.9.11~20151211-1~wily1

Now, the curious thing is that my manpage shows nothing about self-connections. I was using qjackctl but after your mentioning it I remembered seeing it in Cadence. I don’t know how that option is passed to jackd but now is working. But, still strange, now even if I restrict self-connections in Cadence (stopping and restarting), it works in ardour no matter what the setting. I’m really puzzled but, since it works, I’ll try to forget about it.

Thanks for pointing me in the right direction.