Ugly static during playback

I’m trying to use JACK but I am getting heavy distorted static during playback. I can hear the sound correctly but the static is on top.
A program like ZynAddSubFX works fine when JACK is turned off but not when JACK is on. Obviously Ardour doesn’t playback correctly at all.

This is the output from my aplay -l

card 0: VT82xx [HDA VIA VT82xx], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: VT82xx [HDA VIA VT82xx], device 1: AD198x Digital [AD198x Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: UA25 [UA-25], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

I have tried running JACK and JACK-enabled applications using sudo and turning on realtime scheduling, but this doesn’t help the problem.

I am using the alsa driver and I’m running Gutsy.

Any help would be greatly appreciated. I feel this is the final step to being able to record some music without having to switch back to Windows.

Hi, thanks
I had JACK setup with the UA25 as the input and my onboard card as the output. It had no problems with the UA25 as the input, I was just getting static during playback through the onboard card.

Using the UA25 for output works fine.

I was hoping to use the onboard card for output, but I guess its not a big problem to switch to the UA25, at least when I’m using JACK.

BTW. I just “upgraded” from Gutsy to UbuntuStudio and so far have been very pleased.

Jackctl setup.

Are you sure Jack is seeing your UA25? Try interface= hw1. For USB audio cards they recommend periods/frame = 3

Anyway, if you are not using your onboard audio-card at all you’d better disable it in the BIOS and then type in the console “cat /proc/asound/cards” to see that your UA25 is the only one and 0. Then the default setting for the interface in Jackctl will work.

Maybe ardour is the Linux audio application you want to use, but there is much more to the Linux audio world than ardour. I don’t know about Gutsy but if you want to record audio you should first begin by checking if your kernel is optimized for real time work (is it a low latency kernel?), make sure that your UA25 is supported by Linux, JACK configuration is essential… There are some distros specially made for multimedia applications that offer a low latency kernel and a lot of audio and video apps: 64Studio, planet CCRMA, UbuntuStudio, Jacklab and more. I run 64Studio and haven’t worried much about configurations. I’m sure that, for audio at least, Linux can get a better performance out of your hardware than Windows.

don’t mix up gears like that. I think it is a bad idea. Use only one gear for inputs and outputs (much safer in terms of performance). I also see that your onboard sound uses a VIA chipset. Somewhere in the ardour website, it is mentioned that they are the worst you can use for serious audio work … avoid it altogether, only use JACK with your external gear. That’s my advice.

I know that is a resurrection post, but I just wanted to mention my solution because others might have the same static problem and it was completely resolved by:

  1. making sure I have a long enough buffer (at least 5ms for me, 128frames/period, 2 periods/buffer)
  2. using the ‘seq’ MIDI driver instead of the ‘raw’ option in QjackCtl setup (after selecting real-time ALSA)

@x42 I think discourse can have its dating stamp better presented so that the year does not look like the day. Here Nov '07, looks like the topic was written just last month, when in fact it was written in 2007. ‘Nov ‘07’’ appears to look like the 7th of November, and so we end up getting notifications for things going back over a decade…