UCA-222 USB interface problems

I cannot for the life of me figure out how to get the inputs to work on the Behringer uca222.

I set it as the default soundcard in my ~/.soundrc file and it plays back fine, but when I bring up alsamixer all is shows is a PCM and one Mic capture but I cannot get any audio through to the system from the inputs. I have a mixer connected from the tape outs to the uca222 with a guitar going into the board, everything is fine there (monitoring out of the board). I also tried to go direct from the amps direct outs, nothing…

And another issue that is happening… I get a warning when ardour starts up saying my audioengine is running at 8000 Hz. and the session was created at 48000 Hz (with my previous onboard soundcard). In qJackctl it’s set at 48000 Hz in duplex mode so I am not sure.

Any suggestions?

I’m with ya. Outputs are good… Somebody?


Probably just a typo but in your post it says ‘~/soundrc’ the file in your home folder should be ‘~/asoundrc’. Another possibility is the Kernel you are running, and did your UCA-222 work previously. I would google and see if your device is one of the few affected by the ‘Great Kernel USB Audio screwup’ of this past year where Kernels beyond 3.6 had broken USB Audio support, some devices were still not working as of Kernel 3.10.

Some USB Audio devices were not affected so bear that in mind, If you can’t get anything else to work that could be a possibility.


Sorry please note that I should have said ‘~/.asoundrc’.