Ubuntu Studio and ZynAddSubfx messed up

(fasteddy13) #1

Hi all…

Anyone out there using Ubuntu Studio, and managed to get Ardour and ZynAddSubfx to work?

Spent several hours trying to work out how to get the 2 of these to work together… Have each one working on their own, but cant seem to get them to work together. Ubuntu Studio comes with ZynAddSubfx installed, in fact 3 flavours - Alsa, Jack and OSS (whatever that is), but I think, and I may be wrong, that I need the LV2 plugin in order for ZynAddSubfx to work in Ardour.
I found a guide online to installing the plugin;
But it calls for un-installing the currently installed versions of ZynAddSubfx before installing the LV2 plugin version, something I am reluctant to do unless I know I am on the right path…

Anyone know, been there done that and can point me in the right direction?


(Insignia) #2

I use Ubuntu Studio and Zyn was not preinstalled. Perhaps you are using an outdated version - Try updating your version and reinstall Zyn. Hope this helps.


(elcalen) #3

Yeah, to run it from inside Ardour you’d want either an LV2 or VST plugin. I’m not familiar with Ubuntu Studio, but I know the version in Debian’s repository didn’t come with all the plugin versions, and I had to manually build and install them. (Of course if you happen to have more money than I do and want to support the developer, there’s also the option to buy pre-built binaries…)


(fasteddy13) #4

Hi Insignia, elcalen…

Just did ‘lsb_release -a’ and it came up as;
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic

Installed this copy of Ubuntu Studio 2 weeks ago and got thought it was the latest, but… I have just been reminded by my son that I did not do an update after installing… oops…
Doing an update now, then prob a reboot… Will try it all out again then and report back…
Just in case it makes no difference, did either of you guys look at the link I posted? If so, can you see if it looks the right way to go to get the plugin installed?



(fasteddy13) #5

Did a full system and software update, rebooted and ZynAddSubfx is still installed (all 3 versions)… Guess my next step is to uninstall them all and try to follow that guide to install the LV2 plugin version, unless you know of a better guide?
All this is because I started watching Unfa’s video guides on yootoob, but he is a big user of ZynAddSubfx and so I cant follow along with his guides unless I have it… and of course, ZynAddSubfx also looks amazing to play around with…
As for buying the full version, gonna hold off for the mo at parting with my money. Like Ardour, I want to get into it a bit and see if it is something I want to stay with, if I do, then no probs to contribute to the cause, it will be well deserved for all that hard work they put into it…


(elcalen) #6

I believe that link in the first post is to the same instructions I used to build it on my Debian system. It worked for me, your mileage may obviously vary. Compiling software yourself can be a little daunting for sure, and can take a while…

Again, I’m not familiar with Ubuntu Studio, but if you can’t find ZynAddSubFX in Ardour’s plugin list (it should appear for instance in the instrument drop-down menu when adding a midi track, or in the plugin manager), then my best guess is that the LV2 plugin version is indeed not installed, and I don’t know if there’s any other way of easily obtaining it, besides buying it or building it manually. I seem to recall unfa’s channel having a video about installing Zyn. I haven’t actually watched it since I already have Zyn running, so I don’t know if it contains anything useful for your situation…


(fasteddy13) #7

OMG… you weren’t kidding about it taking a while to do… Think it was quicker to install the entire Ubuntu Studio than the Zyn dependencies… But it has all gone in ok so time to have a play, will report back how it goes… Am assuming that the guide had me do everything correctly and that I dont have to do anything else…
Gonna have a quick reboot (sigh, old Windoze habit) then give it all a whizz…

Laters… :slight_smile:


(roithamer) #8

You probably now that, but just for the record, in Arch installing zyn-fusion is simply a matter of :

yaourt -S zyn-fusion


(Erich) #9

Hi there,

I’m the council chair / project lead for Ubuntu Studio. Unfortunately, ZynAddSubfx is one of those packages that we get from upstream Debian that we haven’t seen any changes to for a while.

That said, @lenovens, an Ardour developer also on the Ubuntu Studio team, has brought this to my attention and I’m currently working on the package. Any update won’t make it in time for 19.04, but hopefully we’ll be able to add this to our backports PPA.

The unfortunate part is the upstream Debian maintainer of ZynAddSubfx hasn’t been seen in a long time. He was the maintainer of many packages in Debian, and his absence has created a huge hole in the Debian Multimedia Team and, therefore, a lack of many updated/fixed packages in Ubuntu.

I thank you for your patience on this.


(fasteddy13) #10

Hi roithamer… Not sure of the difference between Ubuntu Studio and Arch, but the guide worked…!!

Now I can proudly call up Zyn as a plugin in Ardour… Hurray…! …ah, seems my entire system is using my Nvidia graphics card as my default audio device… mmm… Think I can sort that out…
Back soon when I can report a 100% success, but it is looking very promising…


(fasteddy13) #11

Hi Erich…

Wow… looks like I accidently summoned a Linux god…!! Not entirely sure what you are saying to me, am new(ish) to Linux and am very much on the vertical face of the learning curve right now…
If you are saying that you could get Zyn into the install of Ubuntu Studio in a future release or update, then wow x 2… and thank you…!
Love this distro so far, nearly talked a few friends into going for it and have got them trying a live version on a usb stick… You guys are remarkable putting all this stuff together, am currently in the worshipping postition as I type… Thank you…!!!


(fasteddy13) #12

All good… no… all fantastic…!!!

Everything working…!! If any other noobs out there follow the guide as I did to install Zyn, then watch out for the default soundcard to have maybe shifted, especially if you have a Nvidia graphics card…
Easily fixed though and now have endless fun ahead playing with Zyn in Ardour… Thanks all for your help, has made my day…!!


(fasteddy13) #13

One final word on this… By going through the guide from the link on the first post, it seems to have reset the audio on my system. It had reset my Nvidia card as the primary audio device and also reset my blacklist file…
Jack was not picking up my midi controller or soundcard. Fortunately, I had already used this forum to find out how to setup my audio system properly so I just did that, and now everything works again… Worth it all in the end… gonna go play with it all now…!


(fasteddy13) #14

I take it all back… Following that guide has seriously messed up my system… Ardour is doing some very strange things now;
file menu keeps disappearing
midi controller randomly comes and goes
midi notes suddenly increase in volume, then go back to normal
midi regions keep shrinking
importing midi notes, some remain silent…
couple of crashes…

Also have to manually start Jack before Ardour now or it does not allow my midi controller…
Pretty sure I have not seen all the problems so far but am already thinking of wiping my hdd and starting again… Can’t recommend following that guide at this time if this is the result…


(elcalen) #15

Uhh, that sounds really weird. But I don’t see how installing Zyn could cause any of that. It shouldn’t be changing anything on your system, and it should be installing the new files in its own directory (by default probably /opt/zyn-fusion). And none of that should be affecting your system’s audio settings or Ardour… (Unless someone’s really effed something up with the most recent updates of Zyn since I installed it, but I would think that’s unlikely…)

Midi support in Ardour isn’t quite perfect, and there can be occasional glitches, but what you’re describing sounds much worse than anything I’ve seen and I’m not sure what could cause it. Are you certain your midi controller, soundcard, etc are functioning correctly? (I should note that I’m definitely not an expert on any of this, though.)


(fasteddy13) #16

Hi elcalen…

Everything was working flawlessly until I went through that install guide for Zyn… From that point nothing has worked properly and as I mentioned, it had completely reset my audio and blacklist file (I had blacklisted the Nvidia audio ‘blacklist snd_hda_intel’ but that was now missing from /etc/modprobe.d/blacklist.conf)

Certainly when building those dependencies it felt like a hell of a lot was going on, took ages with huge amounts of config going through the terminal, especially when the command ‘ruby build-linux.rb’ went through…
Am currently trying to setup my audio as it was before but I am not making much progress and the problems remain… Getting close to giving up as it takes about 20mins to install Ubuntu Studio, already been fighting these problems for several hours…


(elcalen) #17

Compiling software from source takes time and displays lots and lots of messages. That’s entirely normal. And that ruby command is where the actual compiling happens, the rest of the commands are just preparation and then installing the finished product. But all the work it’s doing at that stage should take place in the directory where you downloaded the source code with the git command. It shouldn’t even have the permissions required to touch anything in system directories like /etc.

Clearly your system is messed up somehow, but I still don’t think installing Zyn would have caused it… Or if it did trigger the issues, I feel like there would have been something messed up with the system already. I’m not sure why you’d need to blacklist audio modules. But again, I’m not an expert, and I’m not familiar with Ubuntu Studio, my experience is entirely with Debian…


(fasteddy13) #18

Hi elcalen…

Trust me, that Zyn install was what messed everything up, I have a quite powerful PC that was smooth and fast up until that install. Had 10 mins playing with Zyn in Ardour last night, fired it up this morning and had to manually configure Jack and my soundcard, Zyn seemed to work ok and then the glitches began and just got worse over the next hour or so … I gave up after I posted the last message and have re-installed Ubuntu Studio from scratch… Everything is flying along smoothly again and Jack and Ardour are whizzing along with no issues…
Am going to give up on Zyn for the moment and wait to see what Erich can come up with in the way of updates that may resolve the issue. Shame as it looks like endless fun but unless there is a better way of getting the plugin I will wait…
roithamer mentioned that in Arch he uses ‘yaourt -S zyn-fusion’ but that looks like an unfamiliar command to me so will investigate a bit further before trying that…


(Rghvdberg) #19

Late to the party but if you add the KX studio repos you’ll have Zyn and all the other latest and greatest plugins, apps, etc etc.
Read carefully and don’t skip any steps.

PS. Maybe it’s mentioned before in this thread but I was too lazy to check :yum: