Ubuntu 12.04 / LinuxMint 13 Mate FFADO xruns

Hey Guys
I’m working since 2 years with Ubuntu Lucid 10.04 LTS with FFADO (M-audio NRV10), Jack v1 in realtime mode, and with this system Ardour2 works perfectly without xruns at all and without any problems. Wow.

Now I decided to upgrade the studio to Ubuntu 12.04 LTS, had some xruns with the same hardware config. I thought maybe because of Gnome3, so I installed Linuxmint 13 MATE (amazing stuff btw, i’ll keep it!!! I’m so happy that all the work for the nice Gnome2 is not lost, but still in developpment under the MATE Desktop. one Yes for the opensource comunity!)
Anyway now I have the same config (Gnome2), with a new OS (12.04), a new kernel of course, new FFADO version and new ardour version, but i still get sometimes xruns with Ardour. And it seems to be only with Ardour!

I tried all the config stuff I could find on the internet, but it still the same…
I tried yesterday the whole day and the whole night…can’t get this issue fixed!!

Someone an idea??
Is somebody working with Ubuntu 12.04, FFADO and ardour without problems???

Any help is welcome!!
All the best


ps: would be so sad to reinstall lucid only because it worked there perfectly…

oh thats crazy… I just tried the

kxstudio lowlatency kernel

and not everything works fine!!!
recording since 20mn without any xruns.
sometimes the solutions is so close… :wink:

Working config now:
Linuxmint 13 MATE (Ubuntu 12.04) with kxstudio lowlatemcy kernel, jack v1 and FFADO with a M-audio NRV10

thanks for the answer and the new input :wink:


I have often heard that vanilla Ubuntu is not well optimized for professional audio, though I do not use it myself. I suggest trying Ubuntu Studio, kxstudio, or Dream Studio for better audio performance. Otherwise, tune up your system by following the advice here: http://wiki.linuxmusicians.com/doku.php?id=system_configuration