... turn off auto save

How do I turn off the auto save feature so when I close an unsaved session it reverts to the last saved point. Example: I open a session and name it… save… I add three audio track… close the session and choose not to save. Next time I open the session those three tracks should not be there, but they are. How do I stop this from happening?



have a look at
Options -> Miscellaneous (or similar) -> make periodic savety backups

Looks like you can turn it off there, though I haven’t tried it.

Benjamin Scherrer

Snapshots are your friends. I make a snapshot every time I finish a task or particular series of tasks. This way the latest version is always saved under the main project, but the snapshots represent any given point along that path. After you get used to it, you can not imagine working without it.


Adding new tracks & busses, and any captures (recordings) cause Ardour to always save the session state. This is not auto-save (which is a periodic “safety” backup, and doesn’t write to the “real” session file). It cannot be turned off.
We do not want you losing such major changes to the session state. As noted by Quentin, use snapshots for more flexibility.