Trying to save project to server

I am trying to save a project to a server. I do some of the work on my desktop and live recording on a laptop in another location. So I need the project to live on a server. If I just “save” there is no error message. then when I try to quit, it tells me that I have not saved and gives me a “save and quit” option. I take this and get an error message stating that Ardour could not save session. There are no error codes or othermessages. So I just quit and go to look at the server location and it looks like all the files are there, but if I try to open it, it is just an empty session or it acts like it’s not there depending on how I try to select it.
If I create the same session but just take all the default locations, (home directory) it works just fine.
Any help appreciated.

W. Evans

How do you access the server?

Note that Ardour sessions are case-sensitive, the file-system must also support that.

Furthermore audio files are usually directly mapped into memory (mmap on Linux/macOS, CreateFileMapping on Windows). So the network-file system must support this.

Check Ardour > Window > Log – and see if there are any messages when saving the file.

PS. In general it is not recommended to use a NAS for audio-sessions, while you may have sufficient bandwidth, the throughput may be insufficient.

1 Like

I’ve tried it both with native linux share and Samba. It does write the files and it looks just like the one that works (local)

Willy Evans

I have just tested this with NFS and that works.
The remote system is also a Linux host that exports a ext4 filesystem via NFS v4.

I’ll keep experimenting.
Thanks for the input.

W. Evans

I save all sessions under Linux using NFS on my NAS server and everything works as a charm, including multitrack recording. My disk I/O subsystem had no performance issues. However, I have never tried smb protocol.

Cool. I’ll try again with non-smb and see how it goes.

W. Evans