Trying to install Vital

I have seen the post about vital not being statically linked ( which I don’t understand ) however I can’t get it to work by placing the .so files in the plugin directory.

I can Only get the standalone Vital to run .

I have tried the .deb file which successfully installs the LV2 but ardour will not run with the Error :

2020-11-28T11:03:10 [ERROR]: LV2: Failed to instantiate plugin

I have tried the various binaries in the default folders , Ardour does not even see them .Carla cant see vital when you re scan .

System i s Ubuntu Studio 20.04

Many thanks


Once a plugin fails to instantiate correctly it tends to get blacklisted and you have to clear the blacklist for Ardour to try again.

That being said, Vital is not statically linked, so it tries to use external libraries on your system that may or may not be the correct version for what you need to do. As a result that plugin just has issues on certain systems, and the author should and would need to statically link the plugin at compilation in order to avoid this.


Thanks Seablade .

I fiddled on a bit this morning but even the VST3 version gets
blacklisted straight away. Seems a bit odd that the plugun writer has
not sorted this as I have Ubuntu studio 20.04 , surely one of of the
more likely linuxes you would expect to encounter.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.