Trying to get USB interface to work with Jack - cheapo one

Trying to connect a usb device up to Jack to use ardour or something similar to record with…

at first i hadn’t realized that i had the realtime kernal ticked… props for that! lol… then i realised i hadn’t selected the usb device itself… but past that I’m stuck

in the settings I’ve got usb on HW:1,0.

I’ve got nothing connected in connections as only have 14:midi through on both sides, obviously ardour comes up when it’s running

getting the following error codes:


12:21:51.830 Startup script…
12:21:51.831 artsshell -q terminate
sh: artsshell: not found
12:21:52.239 Startup script terminated with exit status=32512.
12:21:52.240 JACK is starting…
12:21:52.241 /usr/bin/jackd -R -dalsa -dhw:1,0 -r44100 -p1024 -n2 -C
12:21:52.250 JACK was started with PID=7795.
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread -1563601168, from thread -1563601168] (1: Operation not permitted)
cannot create engine
12:21:52.287 JACK was stopped successfully.
12:21:52.288 Post-shutdown script…
12:21:52.289 killall jackd
jackd: no process killed
12:21:52.710 Post-shutdown script terminated with exit status=256.
12:21:54.377 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

any ideas on how i can get it to show in the connections panel too?

is there a Jack forum? I’m using Qtjack… or whatever it’s called…

the device is a UA161B bought from
it was only cheap and it worked in windows but was very very quiet. Hoping that i can find some kind of volume booster but that’s by the by… planning to get something better in the future.

any help greatly apprecieated!!!

I don’t know of ANY USB device that is “not supported by ALSA but is supported by OSS” and in fact your paste of /proc/asound/cards demonstrates that the card is known to ALSA. As long as it a USB Audio class-compliant device, then ALSA supports it.

Relevant information:

cannot use real-time scheduling (FIFO at priority 10) [for thread -1563601168, from thread -1563601168] (1: Operation not permitted)

Please read the FAQ at

The “realtime” option in JACK has almost nothing whatsoever to do with “a realtime kernel” (other than the detail that a realtime kernel will make JACK work even better when run in “realtime” mode).

hmm… didn’t make that much sense… does ardour have a manual?

i can run jack if i run

Jackd -d alsa hw:1

but i still can’t run it from the shortcut… tried removing the artshell command but lock up completely…

any ideas?

And just because Paul didn’t specifically mention it, Jack and Ardour are two separate pieces of software. Jack is not part of Ardour, though Ardour depends on it.

And yes there is a pretty out of date manual for Ardour. A new one is being written but is not quite ready for public consumption yet.


thanks… I’ll check it out and hope I can understand it! lol…

Please google: jack realtime limits.conf

Consider adding the name of your linux distribution to the search.

This is the MOST common issue people have when starting to work with JACK. The FAQ at attempts to answer this. If you do not understand what was written there, please explain what you did not understand (and perhaps, which parts you did)

I know that they are separate programs, I just thought I’d get more help on here. Tried Ubuntuforums but haven’t had a response yet.

I looked at the jack faq, added the lines but it still doesn’t start via the menu icon. as i say it runs through the terminal prompt then i can run jack control and it works fine.

JACK compiled with System V SHM support.
loading driver …
Enhanced3DNow! detected
SSE2 detected
creating alsa driver … hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback

This is what i get when it’s running before i start Jack control.

**** List of CAPTURE Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 2: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: default [USB Audio CODEC ], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

These are the devices i can capture, looking at the code when jack starts via terminal command it’s using the on board sound card.

is there something in the main sound settings for ubuntu that i would need to change?

When it is connected via the terminal command it shows in the audio tab in connections capture_1 and capture_2 in readable clients and playback_1 to 6 in writeable clients… just being dim but the capture bit is the in and playback is the out?

when loading ardour in the readable i get auditioner/out 1 and 2, click/out 1 and master/out 1 and 2, and on writeable clients as master/in 1 and 2

anyone know what connections should be made? what the connections are? or would the old manual for ardour cover any of this? is there a full guide on if so where is it?

sorry to be a pain… I’ve recently switch from windows though I’m sure I’ve had it working in the past when i used ubuntustudio.

My PC is an amd64 x2 4400+ with 6gb ram… i didn’t really want to use windows as i was having sever issues with it crashing all the time and i know linux is rock solid…

as i say if there’s something other than the jack FAQ to read I’d do that! unless i haven’t read it properly, thought i had…

JACK requires the exclusive access to the sound device, and it doesn’t like
anyone else accessing the device before it.

When you use openSUSE
Try to figure out which process is using the sound device by “fuser -v /dev/snd/*”
I think pulseaudio .

I discovered what the problem was… it was the USB device not being suppoerted in ALSA… but it is supported in oss…

so now jack seems to work but now I still can’t get anything to record in ardour… think i may have the connections set up wrong… possibly could just be the cheap interface… i think i’m gonna bin it and try a proper realtime music distro… got a suse based one i’m gonna try from a live cd or usb if it’ll work… may just be the ubuntu thing… and the fact i don’t seem to know what i;m doing!

Paul was trying to point you to the revelant information… This question gets answered so many times it is rediculous.

Quite frankly I want to slap somebody for this but on Ubuntu at least QJackCTL defaults to having the Realtime Option checked and not having it enabled in the security settings so by default it fails. This is just plain retarted.

Anyways your problem is that jack is asking for permission to run at a higher priority than is usually allowed for user applications. You need to make a few configuration changes so the computer will let jack do this.

Hello Shugs81,

if you’re running Ubuntu (I suppose you do if you post at ubuntuforums), why don’t you use qjackctl? It is a frontend to Jack and it’s much easier to handle than a command line tool. Just install via Synaptic or type “sudo apt-get install qjackctl” and there you are.