Trouble with LV2 Plugins - FIXED

I’m having an issue on Linux, Kubuntu 22.04 and the latest Ardour 8.1. I posted this on another thread but guess I shouldn’t have tried to hijack it, so starting one here where it’s more appropriate. Been working on this all weekend.

Several of my LV2 plugins will not show the user interface. In particular, I’m trying to get DrumGizmo to load. I downloaded Ardour 8.1 yesterday and built it and overall it’s working great. Ardour says it finds it and lists it in the plugin manager. I can install it on a track, but when I double click it, I get the generic configuration and I can’t load a drum kit into it.

At the start, I was using the Kubuntu repository drumgizmo plugin, v0.9.18 I think. To try to fix drumgizmo, I downloaded version 0.9.20 from the website, compiled and installed it. I made sure it was all being loaded correctly and there weren’t any issues with other copies. No luck. Then I updated LV2 to version 1.18.10 and rebuilt Ardour and DrumGizmo using all the same libraries, but still no luck. I ran ardev from the command line and noticed that the parent->child is NULL when I try to load it onto a track, which I think is the overall problem, but I don’t know why it’s doing that or how to correct it without diving deep into the code.

So I tried a few more things.

The DrumGizmo GUI test works. Carla loads correctly in Ardour and display it’s GUI, though it’s a VST plugin. I loaded Drumgizmo into Carla and it works just fine and I can get to my drums that way. But Ardour still will not it correctly, so that may be a workaround. I’d rather not have the overhead from Carla though if possible.

It feels like an issue with Ardour, and I can’t track it down in my configuration. I was pretty successful making sure all the dependencies were met for Ardour. Just a few on features I don’t use like on some specific hardware were complaining. But it would seem that a lot of people would point out on the forum if their LV2 plugins stopped working across the board, but not seeing much traffic on it, so that points back to my build.

I also have Ardour 6 installed from the Kubuntu repositories and it loads and displays the same DrumGizmo plugin just fine.

I looked through the config.log from the build and there are some test programs that failed to compile, but other than that, it all seemed pretty good. I can post that if it will help. I figured the test programs that failed were just out of date. In most cases they failed because they couldn’t find a file that I figured had been deprecated.

I know you’ve said you don’t support if we build it ourselves, but I don’t need help with the building process, just a clue or two on what might be causing this if you have any. Any help is appreciated. Is there some other dependency that might be blocking Ardour from loading a lv2 plugin? Maybe a command line parameter I need to include on the build? I’ve looked through the documentation but can’t find anything.

Have you compiled Ardour yourself?
and if so, check Menu > Help > About > Config if

LV2 UI embedding: True

if it’s false, then you missed libsuil-dev as build-dependency.

Perhaps try with an official build (demo is fine, it can be installed in parallel with distro versions, and comes with an uninstaller). or a build.

1 Like

Yes, I built if from the tarball, and yes, you nailed it… LV2 UI embedding is FALSE. I will check that dependency and try again. Not sure how I missed it but maybe I didn’t realize it’s importance. Will post back when I have some results. Thanks!

Yep, that was it. DG is loading just fine now and giving me the interface. Thanks again for your help. Thought I had done a pretty good job at the dependencies, but just too many and too new to the build. Haven’t built Ardour since the 5.x days. Would love it if the Ubuntu repos were updated with it, but totally get just not the time to support all the distro’s out there. Love Ardour. You guys are awesome.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.