trouble with an RME Multiface II + HDSPe card

Hi Everyone,

I’ve got 2 questions, and one of them requires no introduction:

  1. Does anybody have an actual working setup with the HDSPe card (either the expresscard one or the PCIe one) and a Multiface II? If so, what are you using? And what OS/kernel?

My other question:

  1. Why doesn’t it work for me?

might benefit from some background info:

I bought an RME multiface II and HDSPe card (the expresscard host interface) a few months ago and so far it’s been a massive pain to deal with. At first, it was merely finicky, plug everything in, maybe it works, if you’re lucky run:



and everything’s fine. Sometimes the card didn’t even show up in the lscpi output.

So what can I do? Unplug everything, turn it off, turn it back on, usually stuff works.

I started having trouble where I would get the card recognized in lspci output, but have trouble with the firmware:


hdsploader - firmware loader for RME Hammerfall DSP cards
Looking for HDSP + Multiface or Digiface cards :
Card 0 : RME Hammerfall DSP at 0xf7c00000, irq 18
Upload firmware for card hw:0
Hwdep ioctl error on card hw:0 : Device or resource busy.

Something that I learned back when the card was merely finicky instead of completely non-functional, was that you can get this error if you’ve already loaded the firmware, in which case you’re supposed to fire up hdspmixer and start recording. (I’ve always had to do a ‘reset to defaults’ in hdspmixer before I could use the card). So I’ve taken to trying to start hdspmixer first, then trying to load the firmware if that fails. I still can’t get the thing to work, though. While the internet knows about this error message, I’ve tried everything suggested that I’ve come across already:

*) Try a different version of the the alsa-firmware
*) Try a different kernel
*) Unplug everything, plug it all back in, try again (that used to work)

Eventually, this thing basically quite working entirely. I even tried to load the thing on windows (no luck). Shipped it to Synthax (RME’s North American Support partner), they said it looks fine to them, shipped it back.

The thing still doesn’t work, I’ve tried it in 5 different computers (booted all with linux and also windows on 2 of 'em). It hasn’t worked in any of them. On windows, totalmix recognizes the the HDSPe card, but not the multiface II. On linux, I can usually see the HDSPe card in the lspci interface and start hdsploader, but I can’t actually load the firmware.

I"ve tried running the firmware flasher on windows to flash the firmware on the HDSPe card to rev. 20, then downgraded by to rev. 18. I’ve tried a number of different linux kernels, and a few different versions of the RME firmwares from alsa-firmware-utils.

Nothing works. I’m basically at my wits end with this thing.

Anybody here got any ideas?

I have no particular insight into this at this time other than to note that for several years, there has been no need to run hdsploader ever unless you are doing very unusual things. The device driver and kernel take care of this task.

I did notice that I didn’t have to reload the firmware if I didn’t power the multiface II off between reboots, otherwise, I think I always had to run hdsploader before I could get anything (e.g. hdspmixer) to work. By the time the card basically stopped working, I eventually noticed that there was something in the boot logs about trying to load firmware to the card, and failing with a suggestion along the lines of ‘try hdsploader’. Unfortunately, by this time, hdsploader almost never worked. (I can’t remeber, maybe I got it to work once or twice, certainly not many times). I don’t think I’m doing anything weird, but maybe I’m just unlucky.

I was really hoping the guy at synthax I’d talked to would find something wrong with either the expresscard or the multiface ii since it really seems like something is not right with the thing. But he said the thing checked out OK.

Anyways, thanks for your response Paul!

this is the exact setup that I have and it gives me no issues at all, I run ubuntu 12.04 but updated the kernel to 3.11. Anyway, you need a package called alsa-firmware for the card to work, and you need a script to load hdsploader at boot time. you also need to load hdspmixer in order to use the card. I might give you further details once I get in the studio and see what I did cause I don’t remember exactly now…

this might not be the solution, but everytime i reinstall debian or ubuntu linux i do this to update the firmware and then my card works flawless (I have pci / pcmcia though)

I use already couple of years pci-expresscard in combination with the multiface2. Works out of the box.
The module gets loaded on startup and it’s loading the firmware. Only thing i have to do before getting sound if opening hdspmixer and that’s it.

Works perfectly here, which is what I have always been led to expect with RME kit.
AV Linux 6.0.4 “Diehard” with the 3.12.19-rt30avl2-pae kernel built by Trulan Martin.
RME PCIE card with Firewire cable.
Motherboard: Gigabyte 970A-DS3.
6 core AMD 3.5 GHz CPU
I’d never heard of hdsploader until I read this thread. If I run it I get this error message:
Unable to open file ‘/lib/firmware/hdsploader/multiface_firmware_rev11.bin’ for reading
??? All works perfectly anyway.
I have a shell script I wrote for setting the internal mixer, just a wrapper for lots of amixer commands, and that gets run from my ~/.profile

Hey, cajmere, what kind of laptop or desktop+adapter are you using with the expresscard? The guy at synthax thinks there’s something wrong with either my computers or the expresscard adapter.

This is the adapter I’ve been using in my desktops:

at the time, I couldn’t find anything else on the market. I’ve been able to find 3-4 different ones since then, though.

I’ve also tried the card in 3 different X-series thinkpads.

I’m using self-build desktop computer with an asus mobo & intel i5 cpu. It’s a hdsp pci-e card so i don’t use a express card.
The multiface2 is connected with a rme firewire cable to the hdsp pci-e card.