Trouble upgrading 5.3 to 5.4

I have a 2010 MacPro desktop running only Ubuntu Studio 16.04. I installed Ardour 5.3, and the install went well; a desktop icon was created which functions perfectly. I tried to upgrade from 5.3 to 5.4. I asked to uninstall 5.3 and install 5.4. The install seemed to be fine; there were no error messages and a message was posted saying install complete. However, it does not appear that 5.3 was uninstalled and 5.4 was installed. Any suggestions for installing 5.4?

Why does it “not appear that 5.3 was uninstalled and 5.4 was installed” ? What are you expecting? What is not happening?

The launcher for 5.3 is still on the desktop. If I click on the launcher, Ardour 5.3 opens. The name on the launcher is Ardour-5.3.0. I was expecting minimally that the launcher would open Ardour 5.4, and ideally the name would change.

Additionally, the /opt folder contains only Ardour 5.3 (I just checked).

Can you copy and paste the output of the installation script? Use the PRE tag to show it is preformatted text to make it easier to read.


Hi, Only been using Ardour for recording and I like the very clear no colouring of the sound
My 1st post with a problem.
The Ardour 5.4 upgrade freezes my PC (Win 10 64bit) think I need to go back to 5.3 or earlier…?

How can I get the earlier release…?



You really should create a new thread for this, this has nothing to do with the topic being discussed here.


Actually, I played around and figured out the problem. I misstyped a command. Instead of retyping it every time I tried an install, I inadvertently used the misttyped command. :frowning: