I have my Frontier Designs Tranzport “working” with Ardour 2.3 running in Debian etch, but am seeing all the problems described by gflossman, specifically, can’t go to last track, and crashing ardour to the point of a reboot. Is anyone using it more stably? If so, how? I also have read about a kernel driver, but haven’t found it.

It looks like there is further tranzport code in 3.0; I haven’t compiled 3.0 as I’d have to upgrade to Debian testing, but will do so if it will get the device to work better.


i regret that the person who was working on the tranzport code essentially vanished. i don’t know when someone will pick up where he left off. its embarrassing, really. sorry for the mess

Thanks, Paul. I’ll have a look at the code and see if it’s within my ability to hack, and email you.

“…if there are enough people interested in this - and helping - we can get done.”

I don’t think that if I’m enough on my own, but I’m very interested in working with the tranzport in ardour!!! I bought that piece a few days ago because I read in the ardour manual that the tranzport would be supported. But the fact is that in the ardour package that I’m working with (ubuntu-studio,64studio) there is no option to select the tranzport as a device in the menu. It works really nice with nuendo under xp, but thats not what I want to work with in the future. So I would be very pleased if the work would go on. Unlikely I’m no programmer so I can’t help hack the code, but maybe there are other things that I could do to keep on going. maybe testing? Let me know.

@mtaht a big THANKS for the job you’ve already done for the tranzport support in ardour.I wish you go on.

Yes, I essentially vanished. I ended up separated from my tranzport, computer, and often, electricity, for nearly a year.

I am embarrassed, too (and I hereby apologize to all and sundry, especially paul), but as I indicated back then, the problems with the tranzport driver were large, and as it turned out, far too complex and difficult to address while on the road. Various people have offered to help only to drop out. (at the scope of the problems?)

I pulled the linux kernel drivers for the alphatrack and the tranzport out of the old ardour surfaces branch a while back, which is now available via git (svn is too hard to cope with given my persistent lack of connectivity).

git clone git://

Some test code that exercises the drivers is in kernel_drivers/test.

I just tested the alphatrack’s kernel driver. It still works as of linux-2.6.22 and linux-2.6.25.

Also tested the tranzport kernel driver, same releases (both on SMP x86_64). Works. The scrollwheel is a happy thing in the kernel driver, I can’t knock the tranzport offline no matter what I do.

The tranzport driver in ardour is in the same sorry state as I left it, barely usable, and the interface between the kernel drivers and the ardour surfaces interface remains undone.

I am settled down for a couple months where I have all the gear I need, and frequent electricity, and sometimes, even internet, if there are enough people interested in this - and helping - we can get done.

I spent some time today playing with 2.4.1 - and I’m very pleased with it, with the exception of the !@#! tranzport and alphatrack support.

I downloaded Ardour 2.5 (source) today, 'scons’ed it, and tested my brand new Tranzport (1 day old) with it. Apparently Debian (and thus Ubuntu and 64Studio?) choose not to include the Tranzport driver in their packages/repositories…

I had to patch the source with this code:
(change the code manually! the .diff mentioned is for Ardour 2.0.3!)
Otherwise I could not reach the last track, and Ardour would hang (100% CPU time) if I pressed “Previous Track” on the Tranzport when the first track was active.

After changing the code, my Tranzport works OK! Happy mixer here! :slight_smile:
I know I have to be carefull with the wheel and with pressing buttons too fast: my Tranzport will(!) disconnect when I “overload” it with events.

For now: works OK for me! Thanks!

For the future: When I am done with my current project (demo recordings and mixing for my band), I will look at the kernel module…who knows :slight_smile:


Bug reported to Ubuntu (missing Tranzport driver):


Hi all. Here’s a temporary solution.

Switched it to using the kernel driver, fixed a couple issues (next/prev track, some display issues.) Requires the kernel driver posted above (via git).

I offer no guarantees and no support – I needed my tranzport to be working and now it is. Although a few of the fixes would probably benefit libusb users as well, I offer this as a temporary solution and not something that ought to permanently go into the tree. With that said, it works well, meters and everything and no losing link no matter how much you scroll. Kudos to Michael Taht for the kernel driver. I didn’t look into whether my old USB setup or whether the kernel driver itself set the /dev/tranzport0 file to root:audio 0660, but mine was fine out of the box.

To patch a vanilla ardour-2.5/ tree, cd into the directory (e.g. ‘cd ardour-2.5’) and do ‘cat | patch -p1’. Then re-run scons and scons install and it should be good.

Ubuntu activity:

This bug was fixed in the package ardour - 1:2.7.1-2ubuntu1

ardour (1:2.7.1-2ubuntu1) jaunty; urgency=low
[ Surfaz Gemon Meme ]

  • debian/control{.in}:
  • Added libusb-dev to enable Tranzport driver (LP: #248269)

Ok, this is still the libusb driver, buy hey, it’s a start!
Now let’s get that kernel driver in Ubuntu(studio)! :slight_smile: