Tranzport -- permissions with udev

Hi all. The instructions in the manual for configuring user-level USB access for the Tranzport don’t work anymore, as hotplug is being phased out. Here’s how to make it work with udev:

A file should be made under /etc/udev/rules.d/ (I went with tranzport.rules, but it doesn’t matter) containing the following:

Frontier Designs Tranzport

SUBSYSTEM==“usb_device”, ACTION==“add”, SYSFS{idVendor}==“165b”, SYSFS{idProduct}==“8101”, MODE=“666”

(That needs to be all one line)

Then run ‘udevcontrol reload_rules’ and you should be golden.


It works! Adding the user to usb group did the magic - and it was so easy!

Thanks a lot!

this don’t works for me,

Hi Jim,

this drives me crazy, I bought a tranzport device last week, but cant get it to work… First let me say, I have gentoo with kernel 2.6.19-rt12, udev enabled and everything works fine (usb stick, usb printer and so on)
Tranzport works (with failures, but it generally works) as root. If I try the test suite (kernel module and test tools) in ardours source dir, every thing works without failures. I tried the way, the manual does, to setup tranzport for normal user, doesn’t work. Then I found your post and tried this the whole night, but I cant get it to work. Ardour says “[ERROR]: control protocol name “Tranzport” could not be initialized” and on the console: Tranzport: cannot claim USB interface. Do you have any idea, what may going wrong?


Can you post the output of “lsusb” when the antenna part is connected to your computers USB port?

Also post the output of “ls -l /dev/bus/usb/[bus number]/[device number]” where bus and device numbers are those of the tranzport device as reported by lsusb. If lsusb does not show the name of the device, you can find out which device it is by comparing the output of lsusb with and without the device plugged in.

here it is:

daw ardour # lsusb
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0402:5602 ALi Corp.
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 003: ID 062a:0001 Creative Labs Notebook Optical Mouse
Bus 002 Device 002: ID 165b:8101
Bus 002 Device 001: ID 0000:0000

daw ardour # ls -l /dev/bus/usb/002/002
crw-rw-r-- 1 root usb 189, 129 13. Mär 23:34 /dev/bus/usb/002/002

The udev rules are not working for one reason or another. The device /dev/bus/usb/002/002 is writable to only it’s owner root and the group “usb”. The udev rules posted by jimduchek should’ve changed that to ‘666’ which means rw for everyone (a bit lacking in security…).

I suggest you add your user to the usb group, logout and login (needed for the permissions to kick in), and try again.

I using kernel with debian unstable.
As root the tranzport controller work. As a user I have no permissions.

I add this new rule into 020_permissions.rules:
SUBSYSTEM==”usb_device”, ACTION==”add”, SYSFS{idVendor}==”165b”, SYSFS{idProduct}==”8101”, MODE=”0666”

and run “udevcontrol reload_rules”

Bus 004 Device 004: ID 165b:8101
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 147e:2016
Bus 001 Device 003: ID 0a5c:2110 Broadcom Corp. Bluetooth Controller
Bus 001 Device 001: ID 0000:0000

rt-ente:/etc/udev/rules.d# ls -la /dev/bus/usb/004/004

—> crw-rw---- 1 root root 189, 387 29. Mai 14:45 /dev/bus/usb/004/004

It seems that the rule do not work. I test it also with GROUP=“audio”, and I test to create a new file called tranzport.rules with this rule inside. Nothing helps. I always get this permissions for the devise “crw-rw---- 1 root root”.
Any ideas?

Sorry, my english is not so perfect.

no idea, but a workaround. Use /etc/rc.local to change permissions if the dev nodes are created before the boot process reaches this level.

this seems to be working here (Ubuntu 8.04 Hardy Heron):

in /etc/udev/rules.d/40-permissions.rules:
in section “# USB serial converters”:
enter this below the other “ATTRS” entry:
ATTRS{idVendor}==“165b”, ATTRS{idProduct}==“8101”,MODE=“0666”

the results:

$ lsusb
Bus 001 Device 004: ID 165b:8101
$ ls -al /dev/bus/usb/001/004
crw-rw-rw- 1 root root 189, 3 2008-07-13 03:32 /dev/bus/usb/001/004

and after disconnecting/reconnecting:

$ lsusb
Bus 001 Device 005: ID 165b:8101
$ ls -al /dev/bus/usb/001/005
crw-rw-rw- 1 root root 189, 4 2008-07-13 04:33 /dev/bus/usb/001/005


on my debian unstable system since today it works very well with this line into my 91-permissions.rules


SUBSYSTEM==“usb_device”, ACTION==“add”, ATTRS{idVendor}==“165b”,
ATTRS{idProduct}==“8101”,MODE=“0666”, GROUP=“audio”, MODE==“0666”

Finally I managed to make in work in Ubuntu Jaunty.
I created 90-permissions.rules and it looks like this:


SUBSYSTEM==“usb”, ENV{devtype}==“usb_device”, ACTION==“add”, ATTRS{idVendor}==“165b”
ATTRS{idProduct}==“8101”, MODE=“0666”, GROUP=“audio”, MODE==“0666”

One of the problems was that quotes symbol " changed to another one, looking almost the same when I copied those strings into gedit, so be careful with those symbols. Hope this will help someone.