Transport control buttons on M-Audio Oxygen8 v2 don't work

I am trying to use the transport keys (play, stop, record, …) of my M-Audio Oxygen8 v2 midi master keyboard. I have already done the following steps:

  1. enabled MMC commands
  2. linked to my system output to MMC input in the MIDI Connection Manager
  3. setup the Control Surfaces to Generic MIDI -> M-Audio Oxygen8 V2
  4. Tried as a MIDI-System ‘ALSA raw devices’ and ‘ALSA sequencer’

I see in the MIDI tracer that Ardour receives the signals, but it doesn’t respond to it.

The MIDI keyboard does however work correctly as a MIDI instrument and also controlling volume sliders works like a charm when I apply MIDI learning to a knob (ctrl + middle click on a slider, then turn the knob). Does anybody know what I can do to make the transport MMC buttons to work? Thanks in advance.

PS: I’m using Ubuntu 18.04 and Ardour 5.12.0

Please use a MIDI monitor (gmidimonitor, kmidimonitor,jack_midi_dump,…) to determine what messages the Oxygen8 sends.

I have an M-Audio Keystation 88, and for reference it does not send MMC commands when you use its transport control buttons.

Thanks for the tip.
It seems that the MMC signal is coming through.

These are the outputs when I push the play button:

Ardour MIDI Tracer [Port = MMC in]
21:38:51.602965 Controller chn 1 13 7f

Ticks ----- Time ----- Source ----- Event kind ----- Chan ----- Data 1 ----- Data 2 ----- Data 3
3057 ----- 6.3703 ------ 20:0 — Control change ---- 1 ----------- 19 ----------- 0 ------------------

I’ve also tried setting the ‘Inbound MMC device ID’ (preferences -> MIDI) to 0, 1, 19, 20, 127 and 128. But unfortunately without result.

That is not an MMC message. It’s just a controller message. Totally different and utterly unrelated to MMC. There’s no reason why ardour would respond to it. You probably want to set up a MIDI binding map for the device.

Alright, thanks for the explanation :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.