tracks out of sync when importing

Does anyone else have this problem ? when I import multiple tracks into ardour, one or two of the tracks will start on zero but the rest of the tracks will start as much as an hour ahead of the other tracks in the timeline and I have to manually drag the tracks back to zero. Takes a lot of time and is a pain in the you know what. Anybody ? thanks, John

Well the first question is going to be what your settings are on import. Depending on those it may be possible you are importing at the file timestamp, and some of the files may have a non-zero time stamp. I can’t remember what will happen if the file is lacking a timestamp in this situation, but it may not be what you expect either.


I don’t know about a time stamp. These are raw .wav files from a multitrack project. All I’m doing is trying to import them to work on mixing. Audacity and Mixbus import them fine, I’m not sure why Ardour does this to me. All the time I might add, with every multitrack I try to import. (sigh) frustrating.

A timestamp is a function of Broadcast WAV files, which can look like normal wav files to most users, but some software creates that.

What version of Ardour do you have? Is there any difference in placement if you import one of the files that was offset by itself?


derbycoat: ardour may have different defaults than mixbus for its handling of timestamped files. Most DAWs that do stem exports or similarly neutral export approaches will typically generate time-stamped Broadcast WAV files. Whether to obey the timestamp or not is an option in Ardour’s import dialog.

Or there may be a bug. We would of course solve this in 10 mins on IRC, but I am assuming that we’re stuck here on the forums. Do you have the program sndfile-info available (it is a command line tool)?

Sorry, my internet is limited to my phone tether. I’m a musician who loves Linux but have never done IRC and unfortunately sndfile-info is over my head. john

I’ve downloaded multitrack files from different sources from people kind enough to offer them freely for the sake of mixing/training/learning. All of the files are full length and the same size as all the others so they all start and end at the same time. I probably am just ignorant of the settings I need to adjust in Ardour to make this work properly.

the point about sndfile-info is that it can be used with the -b flag to determine whether the file has a Broadcast WAV timestamp or not.

Basically you would type in a terminal…

sndfile-info -b FILENAME

Replacing FILENAME with the name and location of your audio file you downloaded. It is easier to guide someone through this on IRC of course but you said that isn’t likely to be much of an issue.


what version of ardour are you using ?

I had this issue when importing backing tracks into ardour, and it would usually always import the track miles away from the start.

recent versions of ardour dont seem to do this

@veda_sticks what you described was the behavior if the import was set to ‘use file timestamp’ and there was no file timestamp. It would then import at the playhead position IIRC. This was changed a bit back, again going off memory, and is a bit different from what the OP was describing which would be on a single import tracks would get more and more out of sync if I understood them correctly.


In regard to the question of which version, the last few versions of ardour have done this but this was with 3.5.357. The newest.

Ugh, yeah, I feel like an idiot now. I found that drop down menu in the import box. Funny thing now when I tell it to import at start of session, it does exactly that. I hadn’t really paid attention to that before. I just made an assumption that the tracks would start at the start. Sorry everyone but thank you for listening. John

You haven’t said what settings you’re using when you import. What happens if you set it to import to the start of the session?