Track reordering woes

I am having trouble reordering tracks and buses using the “Tracks/Buses” pane. I have projects containing many (30+) tracks of audio only (no midi). I am not running any plugins, it is just bare audio without any post-processing (like panning or normalization).

Due to the number of tracks, I often want to reorder the list of tracks so that related tracks are grouped together. To do this, I move to the “Tracks/Buses” pane, and drag-drop the tracks into the order I desire. However, I’m having problems…

My problems fall into two categories:

[1] Drag-drop causes Ardour to crash. This problem intermittent, occuring around 30% of the time I try to drag-drop, and not necessarily with the same tracks. It doesn’t seem to be reproducable.

[2] When I add a new track, or when I change the name of an existing track, the list of tracks/buses is arbitrarily reordered. Each time I do this, it seems to choose a different ordering (I originally thought it would select chronological or alphabetic ordering, but neither is the case - it seems to be entirely random).

The problems are not tied to a particular project - it happens across all my projects.

Is anyone else having similar issues? Can anyone recommend some kind of fix or alternative for achieving reordering?

I run Ardour 2.1 (r.2496 from Kubuntu 7.10) with Jack an Freebob (same repos).


can I recommend you install 2.3 ( which I’m pretty sure is in the ubuntu repos), and see if this fixes your problem? There have been many bugfixes since then, but I admit I never had that problem with 2.1…

2.3 is not actually in the Ubuntu Gutsy repos (or at least, not universe or multiverse.)

is the place to get the newest version for. NB this is not supported by Ubuntu, but I personally have absolutely no qualms about using anything from because it seems perfectly stable to me. I’m afraid I can’t help with your original question, though.

I’ll try 2.3 then (I didn’t compile it from source because of the jack/freebob requirements) and see if that fixes it. I’m still a little puzzled that Ardour made it through to 2.1 with an issue like this, however… Any further advice would be greatly appreciated!

Update: I tried 2.3 (built from source) and it is considerably more stable, especially over track orderings.

I have to say I’m very impressed with 2.3, and I’m quite surprised that the upgrades since 2.1 didn’t deserve a major version - great work! I do miss the edit playhead, however :’(