Track and region confusion

I am having weird problem which I cannot remember I have seen before and do not know how to get out of.

For some reason tracks in the timeline no longer are aligned with the regions. It is hard to know which track belong to which row.
Further it seems like the timeline is also confused because dragging a region to a diffrent “track” is not possible anymore. Apart from this the project works fine… I have a screen shot but i do not know how to attach it here.

Is this a feature or a problem? Is there a way out of it?

Last a nother question. Is there a way of selecting all tracks so that for example all tracks could be set to the same height?

a screenshot may help to diagnose what is going on …

Here is a screen shot!

Sorry, hope this makes it more clear.

aha, using a beta version on OS X … sorry, this just a bug in a3 that shows up more frequently on OS X than it does on Linux. Its cause is unknown. This is one example of the sort of reasons why there has been no official release for Ardour 3 for OS X.

You may find that if you reset all the track heights things will line up again. Or maybe not.

Good to know that it is a known problem (then it is more likely to be solved:) ).
Actually this in Ubuntu (kxstudio) and the latest downloadable build, maybe I should try to build it myself?
I tried to open the project in 3.3 but it fails to load.

Is there an easy way of reseting all track height at the same time?

Thanks, reseting all tracks solved the problem (I made a shortcut to reset a track to normal height).
Still, would have been nice with a “reset all teackheights” command.

shift-ctrl-click a track header to select all tracks. then right click and set Height. all tracks will be affected.

Apologies for the OS X confusion, I didn’t look carefully enough at the full screensot.